Closed Bug 1546395 Opened 2 years ago Closed 5 months ago

The PIP icon is not visible in High Contrast mode

Categories

(Toolkit :: Video/Audio Controls, defect, P3)

All
Windows
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox68 --- disabled
firefox69 --- disabled
firefox70 --- affected
firefox71 --- affected

People

(Reporter: tbabos, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

Attached image PIP button

Affected versions:
68.0a1 (2019-04-22) (32-bit)

Affected platform:
Windows 10
Windows 8.1

Steps to reproduce:

Expected Result:
The PIP toggle button should be visible with the label and the icon while using High Contrast mode.

Actual Result:

  • The icon is not visible for the PIP button*
  • The icon is not visible on the main window - only text is displayed*

Both for High Contrast Black and White

Attached image Main window
Blocks: 1527926
No longer blocks: 1543027
Priority: -- → P3
Attached image Toggle button

Toggle button has also the missing PiP icon on latest Nightly71 and Beta70.0b7 on Windows 10 x64.

Blocks: 1532675
No longer blocks: 1527926
No longer blocks: 1532675

This appears to be fixed. We used to hide background images to avoid issues with text over background images being difficult to read but since morgan implemented the readability backplate, we have enabled background images in high contrast mode.

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.