Closed Bug 1546435 Opened 3 years ago Closed 3 years ago

HTML <select> and <input type="checkbox" checked> are not rendered properly on macOS 10.14.5 currently in Beta

Categories

(Core :: Widget: Cocoa, defect, P1)

defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox67 --- affected
firefox68 --- affected

People

(Reporter: marcia, Assigned: haik)

References

Details

Attachments

(5 files)

After updating to the latest Mac OS 10.14.5 (18F118d), I am no longer able to edit tracking flags on either the latest Beta or the latest Nightly Firefox browser.

I have tried force refreshing, clearing cache, restarting my machine and the issue persists.

  • Using another Mac running 10.12.6, editing flags works fine using the latest nightly.
  • Using Chrome on the same machine, the issue is not seen and I can edit the flags.
Assignee: general → nobody
Component: Bugzilla-General → User Interface: Modal
Product: Bugzilla → bugzilla.mozilla.org
QA Contact: default-qa
Version: unspecified → Production

I just realized if I actually click on the widget, I do see the flags and select something. But the flag choices don't show in the UI like they do normally.

Summary: Unable to edit tracking flags after update to 10.14.5 → Unable to see tracking flags in the UI after update to 10.14.5

This looks like the persistent edit mode is off. What happens after clicking the Edit button?

we chatted some more on slack, I've seen some additional screenshots. this is very weird -- it might be a firefox bug. will try to reproduce.

Assignee: nobody → dylan

Okay, I can reproduce the issue on macOS 10.14.5 Beta installed on Parallels Desktop. The issue is not specific to Bugzilla, so moving this to the right component. You can test it on the <select> article on MDN.

Assignee: dylan → nobody
Component: User Interface: Modal → Widget: Cocoa
Product: bugzilla.mozilla.org → Core
Summary: Unable to see tracking flags in the UI after update to 10.14.5 → HTML <select> element is not rendered properly on macOS 10.14.5 currently in Beta
Version: Production → unspecified
Attached image Screenshot on MDN

Checkboxes are also affected.

Summary: HTML <select> element is not rendered properly on macOS 10.14.5 currently in Beta → HTML <select> and <input type="checkbox" checked> are not rendered properly on macOS 10.14.5 currently in Beta
Duplicate of this bug: 1547095
Assignee: nobody → haftandilian
Priority: -- → P1

[Tracking Requested - why for this release]: macOS 10.14.5 is already in public beta 3 and the issue is visible to user, so it should be fixed soonish.

My testing shows this problem is addressed by the fix for bug 1546836 so I'll close this bug as a dupe. And I'll post a build with the fix later today if anyone would like to validate it.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1546836

Okay, removing the tracking flags then :)

(In reply to Haik Aftandilian [:haik] from comment #13)

https://queue.taskcluster.net/v1/task/N7fO47FcRK2krwJVUokF-w/runs/0/artifacts/public/build/target.dmg

Hmm, this build didn’t fix the form rendering issue for me. Nothing has changed from the screenshots posted earlier.

(In reply to Kohei Yoshino [:kohei] (Bugzilla UX) (FxSiteCompat) from comment #14)

(In reply to Haik Aftandilian [:haik] from comment #13)

https://queue.taskcluster.net/v1/task/N7fO47FcRK2krwJVUokF-w/runs/0/artifacts/public/build/target.dmg

Hmm, this build didn’t fix the form rendering issue for me. Nothing has changed from the screenshots posted earlier.

OK, I've reopened the bug until we resolve this.

Could you describe your hardware setup?

about:buildconfig should show Built from https://hg.mozilla.org/try/rev/f8ba36c1e0a67271161eed5d54bd8dd43416892a with the build I provided.

Status: RESOLVED → REOPENED
Flags: needinfo?(kohei.yoshino)
Resolution: DUPLICATE → ---
Attached file about:support

I see f8ba36c1e0a67271161eed5d54bd8dd43416892a in about:buildconfig.

Flags: needinfo?(kohei.yoshino)

Since I’m running macOS 10.14.5 Beta on a Parallels VM, there are various hardware differences from physical machines. NI Marcia to double check.

Flags: needinfo?(mozillamarcia.knous)

(In reply to Kohei Yoshino [:kohei] (Bugzilla UX) (FxSiteCompat) from comment #17)

Since I’m running macOS 10.14.5 Beta on a Parallels VM, there are various hardware differences from physical machines. NI Marcia to double check.

Running 10.14.5 ((18F118d) with the test build in question, I can confirm at least with bugzilla that the rendering issue is gone, and I can now see the various tracking flag dropdowns. Happy to test other sites if needed.

Flags: needinfo?(mozillamarcia.knous)

(In reply to Kohei Yoshino [:kohei] (Bugzilla UX) (FxSiteCompat) from comment #17)

Since I’m running macOS 10.14.5 Beta on a Parallels VM, there are various hardware differences from physical machines. NI Marcia to double check.

A new version of macOS 10.14.5 Beta was released today. With the new version (18F127a), the problem is no longer reproducible. Kohei, could you confirm the problem doesn't occur for you with the latest 10.14.5 update? Then we can close this bug.

Running 10.14.5 (18F127a) I can no longer reproduce this issue on beta or nightly 68.

(In reply to Marcia Knous [:marcia - needinfo? me] from comment #20)

Running 10.14.5 (18F127a) I can no longer reproduce this issue on beta or nightly 68.

We have a similar situation with bug 1546836. I think we can close this bug as works-for-me. We're going to follow up with Apple and try and get some details.

Updated to the new beta (18F127a) on my VM, and the issue still persists. I think it’s okay to close this bug though.

Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → WORKSFORME

(In reply to Kohei Yoshino [:kohei] (Bugzilla UX) (FxSiteCompat) from comment #22)

Updated to the new beta (18F127a) on my VM, and the issue still persists. I think it’s okay to close this bug though.

Could you file a new bug for your issue with the Parallels VM? It is lower priority than the non-VM Apple hardware case, but we should track it. Thanks.

You need to log in before you can comment on or make changes to this bug.