Closed Bug 1546499 Opened 8 months ago Closed 7 months ago

Downgrade assertion for unexpected child frame in in nsVideoFrame::Reflow

Categories

(Core :: Layout, task, P3)

task

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: dholbert, Assigned: dholbert)

References

Details

Attachments

(1 file)

STR:

  1. Load https://bugzilla.mozilla.org/attachment.cgi?id=9030624 (testcase for bug 1513438 )

ACTUAL RESULTS:
fatal assertion:

Assertion failure: false (MOZ_ASSERT_UNREACHABLE: Extra child frame found in nsVideoFrame. Possibly from stray whitespace around the videocontrols container element.), at src/layout/generic/nsVideoFrame.cpp:376

EXPECTED RESULTS:
This assertion should be nonfatal, since this is something that can currently happen (per bug 1513438) and is not really a serious issue -- there'll just be broken or un-rendered layout.

Also, make the assertion shorter & more to the point. In particular,
I'm removing the note about stray whitespace, which is based on one
previous scenario that caused extra child frames; but I don't have
much confidence that potential future causes of this assertion-failure
will have that specific problem as their root cause.

oops, I missed the r+ here.

Noticed it now (thanks for the review), and triggered Lando.

Pushed by dholbert@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c58def4246ac
Downgrade nsVideoFrame's unexpected-child assertion. r=xidorn
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.