Closed Bug 1546523 Opened 1 year ago Closed 1 year ago

Local runs of raptor-tp6-instagram-firefox fail to load a page

Categories

(Testing :: Raptor, defect, P1)

Version 3
defect

Tracking

(firefox68 fixed)

RESOLVED FIXED
Tracking Status
firefox68 --- fixed

People

(Reporter: mgaudet, Assigned: whimboo)

References

Details

Running a local build of

parent: 526402:831918f009f6 
 Backed out changeset e85cb54e5944 (bug 1546046) complementary backout after 1470880 was backed out CLOSED TREE
branch: default
commit: 1 unknown (clean)
update: 55298 new changesets (update)
phases: 47 draft

I am finding raptor cannot succeed running instagram. All I get is a white page. Web Console has this:

will be measuring fnbpaint measure.js:82:15
got fnbpaint measure.js:180:13
sending result back to runner: fnbpaint 636 measure.js:315:11
will be measuring dcf measure.js:90:15
got domContentFlushed: 1556055387075 measure.js:203:13
sending result back to runner: dcf 636 measure.js:315:11
will be measuring first-contentful-paint measure.js:98:15

time to first-contentful-paint is not yet available (0), retry number 1...
measure.js:282:15
will be measuring loadtime measure.js:123:15
got loadEventStart: 1556055387054 measure.js:298:13
sending result back to runner: loadtime 615 measure.js:315:11
confirmed fnbpaint measure.js:318:15
confirmed dcf measure.js:318:15
confirmed loadtime measure.js:318:15

time to first-contentful-paint is not yet available (0), retry number 1...
measure.js:282:15

time to first-contentful-paint is not yet available (0), retry number 2...
measure.js:282:15

time to first-contentful-paint is not yet available (0), retry number 3...
measure.js:282:15

time to first-contentful-paint is not yet available (0), retry number 4...
measure.js:282:15

time to first-contentful-paint is not yet available (0), retry number 5...
measure.js:282:15

time to first-contentful-paint is not yet available (0), retry number 6...
measure.js:282:15

time to first-contentful-paint is not yet available (0), retry number 7...
measure.js:282:15

time to first-contentful-paint is not yet available (0), retry number 8...
measure.js:282:15

time to first-contentful-paint is not yet available (0), retry number 9...
measure.js:282:15

time to first-contentful-paint is not yet available (0), retry number 10...
measure.js:282:15

unable to get a value for time-to-fcp after 11 retries

then in the log I get

21:37:25     INFO -  raptor-control-server received webext_raptor-page-timeout: [u'raptor-tp6-instagram-firefox', u'https://www.instagram.com/', {u'fcp': True, u'hero': False, u'dcf': False, u'fnb paint': False, u'ttfi': False, u'load time': False}]

Here's the external benchmark info from the log:

Matthews-Space-Grey-Macbook-Pro:unified2 mgaudet$ ./mach raptor-test  -t raptor-tp6-instagram-firefox
Updating external benchmarks from https://github.com/mozilla/perf-automation
Previous HEAD position was 2720cdc Merge pull request #10 from jmaher/wasm-misc
Switched to branch 'master'
Your branch is up to date with 'origin/master'.
Already up to date.
Note: checking out '2720cdc790828952964524bb44ce8b4c14670e90'.

You are in 'detached HEAD' state. You can look around, make experimental
changes and commit them, and you can discard any commits you make in this
state without impacting any branches by performing another checkout.

If you want to create a new branch to retain commits you create, you may
do so (now or later) by using -b with the checkout command again. Example:

  git checkout -b <new-branch-name>

HEAD is now at 2720cdc Merge pull request #10 from jmaher/wasm-misc

Hmm. Yahoo News works fine. But twitter's not working either (same white page, and no metrics)

Hi Matthew, what platform are you running this on? And what are you running Raptor against (Firefox desktop or one of the android browsers)? Thanks.

Don't worry about the external benchmark repo 'benchmarks from https://github.com/mozilla/perf-automation' that only pertains to running benchmarks i.e. speedometer, sunspider. For page-load tests the recordings are all downloaded form tool-tool.

Flags: needinfo?(mgaudet)
Priority: -- → P2

This would be OS/X; good to know about the benchmarks repo.

Flags: needinfo?(mgaudet)

(I'm trying a clean clobber build now, just waiting. twiddles thumbs)

Just updated to

parent: 526827:87829648b0e5 
 Bug 1503657 - Migrate nsINode::localize and DOMLocalization.jsm to use DOMOverlays C++. r=smaug

and I'm hitting the same issue.

(In reply to Matthew Gaudet (he/him) [:mgaudet] from comment #3)

This would be OS/X; good to know about the benchmarks repo.

Thanks, I'm on OSX also so I'll see if I can repro too.

Assignee: nobody → rwood
Status: NEW → ASSIGNED
Priority: P2 → P1

another data point: Just tried central from April 9: https://hg.mozilla.org/mozilla-central/rev/98b223de0543

It also failed: makes me wonder if something is broken for me locally, or if something went wrong with stuff that gets downloaded...

I ran both of these locally on my OSX (10.13.6), using my latest build of Firefox nightly (based on the latest inbound pulled around 2:45pm EST Wed Ap4 24):

./mach raptor-test --test raptor-tp6-instagram-firefox --page-cycles 3

./mach raptor-test --test raptor-tp6-twitter-firefox --page-cycles 3

Both tests ran fine - the pages displayed fine and all measurements were received.

These tests are also passing in production:

https://treeherder.mozilla.org/#/jobs?repo=autoland&searchStr=raptor%2Ctp6-7&fromchange=f7af0a64674d7e54f349f868f69a761d4160aad7

Not sure why it's not working on your setup. :(

Priority: P1 → P2

Hrm. Ok. It's good to know it's just me. Let me try clobbering various downloaded artifacts

Turns out; there were a bunch of raptor_test.py hanging around, presumably from a ctrl-c or two. Something got very confused, mitmproxy was serving yahoo-news to the instagram load attempt.

Killed everything raptor, and tried again and it worked.

Perhaps the net outcome of this bug would be better error checking for the state of already running proxies? Not sure how to resummary this; maybe just resolve invalid?

Status: ASSIGNED → NEW

So :whimboo just landed code to better clean-up after a ctrl + c during Raptor (Bug 1506928) so that should really help. I'd say resolve this invalid for now - and see how it goes with that new clean-up code. If you still see issues in the future feel free to file a new bug, thanks!

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → INVALID
See Also: → 1506928

I have seen similar failures which were also the reason why I was working on bug 1506928. So yes, without leaving processes behind this problem should be fixed now.

Assignee: rwood → hskupin
Depends on: 1506928
Priority: P2 → P1
Resolution: INVALID → FIXED
You need to log in before you can comment on or make changes to this bug.