Closed Bug 1546598 Opened 6 months ago Closed 5 months ago

'Forget About This Site' doesn't work

Categories

(Toolkit :: Data Sanitization, defect, P1)

68 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- unaffected
firefox68 + fixed

People

(Reporter: euthanasia_waltz, Assigned: baku)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

STR for example:

  1. Start nightly with new profile
  2. Go to youtube
  3. Click Settings button and set Dark theme on
  4. Go back to home
  5. Open Library->History
  6. Do 'Forget About This Site' on YouTube in Recent History
  7. Go to youtube

ER:
Dark theme off

AR:
Dark theme on

mozregression:
10:47.33 INFO: Last good revision: b742fcff4f2bd93c8bce4923ca206f1c945d1823
10:47.33 INFO: First bad revision: 2fea4528362ef7e58d2b5fecb1a366352d7c95e4
10:47.33 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=b742fcff4f2bd93c8bce4923ca206f1c945d1823&tochange=2fea4528362ef7e58d2b5fecb1a366352d7c95e4

Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Ever confirmed: true
Keywords: regression
Regressed by: 1515913

Baku, do you have time to take a look at this? :)

Flags: needinfo?(amarchesini)
Priority: -- → P1

I'm not able to reproduce it using the latest nightly. I followed the STR step by step, and at the end, youtube.com is always shown with the default white theme.
During the cleanup, any youtube.com cookie is deleted (all of them are set for host ".youtube.com"), but nothing is deleted from google.com, doubleclick.dom and so on. This is an existing bug of Forget About Site.

Johannh, have you tested this bug? Can you reproduce it?

Flags: needinfo?(amarchesini) → needinfo?(jhofmann)

I can also reproduce the issue on Nightly.
Build ID 20190424215525
User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

[Tracking Requested - why for this release]:
Data sanitization regression

I can reproduce this, too. This seems to affect all cookies with the leading-dot host pattern (".youtube.com"). It is quite easy to reproduce with any site that sets those, not just YouTube.

Maybe removeCookiesFromHostDomain not working correctly? Baku, it's probably fastest if you manage to reproduce this and can debug that function yourself, otherwise I can try to take this. What do you think?

Flags: needinfo?(jhofmann) → needinfo?(amarchesini)
Flags: needinfo?(amarchesini)
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d5a1d15601fe
Remove domain cookies in nsICookieService.removeCookiesFromRootDomain(), r=Ehsan
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Flags: in-testsuite+
Assignee: nobody → amarchesini
Blocks: 1550317
You need to log in before you can comment on or make changes to this bug.