Closed Bug 1546599 Opened 7 months ago Closed 7 months ago

FxA Name is not switched to default state after the user has disconnected from the account

Categories

(Firefox :: Firefox Accounts, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 68
Tracking Status
firefox67 --- verified
firefox68 --- verified

People

(Reporter: maria_berlinger, Assigned: vbudhram)

References

Details

Attachments

(3 files)

Attached image account name.gif

Affected versions

  • Firefox Nightly 68.0a1 (Build ID 20190423221610)
  • Firefox Beta 67.0b13 (Build ID 20190422163745)

Affected Platforms

  • Windows 10x64
  • Ubuntu 18.04x64
  • Windows 7x64
  • mac Os 10.14

Prerequisites

  • Firefox browser is opened.
  • User is authenticated with a Firefox Account.
  • FxA icon is pinned to the Overflow Menu.

Steps to reproduce

  1. Click on "More Tools..." menu button from the browser toolbar.
  2. Click on the "Firefox Account" button.
  3. Click on the "Manage Account..." button.
  4. Click on "Add..." butt for "Display name".
  5. Write a name and click on [Change] button.
  6. Verify that the name is displayed at the top of the FxA doorhanger in the Overflow Menu.
  7. Go to about:preferences#sync and click on "Disconnect" -> "Just Disconnect" button.
  8. Click on "More Tools..." menu button from the browser toolbar.
  9. Click on the "Firefox Account" button.
  10. Observe the name displayed at the top of the FxA doorhanger.

Expected results

  • The name displayed is "Firefox Account".

Actual results

  • The name displayed is the one defined by the user.

Regression range

  • This issue is not a regression.

Notes

  • This issue is reproducible only when FxA is in the Overflow menu.
  • After browser restart the name is changed to "Firefox Account".

Vijay, could you look into this? I expect we need to remove the header and/or clear a title attribute somewhere.

Flags: needinfo?(vbudhram)

Hey :gijs, looked at this and removing the title attribute fixes this issue. Will post a patch soon.

Flags: needinfo?(vbudhram)
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/542aa9819121
Reset FxA avatar menu title on logout r=Gijs
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

Vijay, this looks safe for beta, do you want to request an uplift?

Assignee: nobody → vbudhram
Flags: needinfo?(vbudhram)
Attached patch Bug1546599.diffSplinter Review

Beta/Release Uplift Approval Request

  • User impact if declined: Incorrect header in FxA toolbar menu when user logs out of FxA
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This isn't a risky change because a user needs to have set a display name for FxA, have the toolbar menu be in the overflow view and then log out.
  • String changes made/needed:
Flags: needinfo?(vbudhram)
Attachment #9061380 - Flags: approval-mozilla-beta?
Attachment #9060493 - Flags: approval-mozilla-beta?
Comment on attachment 9061380 [details] [diff] [review]
Bug1546599.diff

Low-risk polish for fxa in 67, uplift accepted for 67 beta 16, thanks.
Attachment #9061380 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9060493 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

This issue is verified fixed using Firefox 67.0b16 and Firefox 68.0a1 (20190502220333) on the following OSes: Windows 10 x64, Ubuntu 18.04 x64, Windows 7 x64, macOS 10.14.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.