combined search (multi-engine search) no longer working

RESOLVED EXPIRED

Status

SeaMonkey
Search
--
major
RESOLVED EXPIRED
16 years ago
8 years ago

People

(Reporter: julius ross, Unassigned)

Tracking

(Blocks: 1 bug, {regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1a+) Gecko/20020625
BuildID:    2002062508

When selecting two or more search engines in the search tab (using advanced
search preference) mozilla brings up a list of results in the sidebar and in the
top half of the main browser window.  Selecting any of these results makes the
sidebar results disappear.

This worked fine in mozilla 1.0.

Reproducible: Always
Steps to Reproduce:
1.Select Preferences-->Internet Search-->Sidebar Search Preference Advanced
2.Select the search engines google and dmoz (not netscape)
3.Perform a search for some word
4.Select a link in the top half of the browser window (labeled "search results")


Actual Results:  5.The sidebar results dissapear

Expected Results:  The sidebar results should remain and the link should appear
in the bottom half of the browser window.

This problem occurs on max osx and linux with a variety of search engines.  

Additional comment:  I wonder if the expected result above is really the best
design.  Firstly because it means that you have the link in 3 places (the
sidebar and in both halves of the browser window).  Secondly the design of many
sites makes it hard to write a plugin which takes advantage of this feature. 
Perhaps showing the target of the url in the bottom half of the browser is
prefereable.

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

16 years ago
Keywords: regression
Summary: advanced search no longer working → combined search (multi-engine search) no longer working

Updated

16 years ago
Depends on: 171383

Updated

16 years ago
Blocks: 171383
No longer depends on: 171383
(Assignee)

Updated

10 years ago
Product: Core → SeaMonkey
Assignee: samir_bugzilla → nobody
QA Contact: claudius → search

Comment 1

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 2

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.