Closed Bug 1546639 Opened 2 years ago Closed 1 year ago

The PiP fly-out does not appear upon hovering on Netflix videos

Categories

(Toolkit :: Video/Audio Controls, defect, P2)

All
Windows
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox68 --- affected

People

(Reporter: tbabos, Unassigned, NeedInfo)

References

Details

Affected versions:
68.0a1 (2019-04-23) (32-bit)

Affected platform:
Windows 10
Windows 8.1

Steps to reproduce:

  • Launch Nightly
  • Go to netflix.com
  • Play any video, movie, etc.
  • Hover over the video to toggle the PiP fly-out

Expected Result:
The PiP fly-out will not appear upon hover on video, play/pause video, etc.

Actual Result:
Nothing happens.
The only action that toggles the PiP button is clicking on the seeking bar or on the fast forward/backward 10 seconds buttons.

Priority: -- → P2

I suspect this will be fixed by a fix for bug 1548296, but I want to make sure, so not duping this one immediately.

Depends on: 1548296

Hi Timea, now that bug 1548296 is fixed, are you still able to reproduce this?

Flags: needinfo?(tbabos)

For what it's worth, I still can. Even before that fix, I've noticed that the PiP fly-out does appear on Netflix, but very occasionally, sometimes after minutes of playback with no obvious trigger.

Also, not sure if related, but PiP can't be forcibly activated via context menu, because the actual video element is overlaid with a full-sized div with control elements, so context menu doesn't contain video-specific actions.

(In reply to Ingvar Stepanyan (RReverser) from comment #3)

For what it's worth, I still can.

To be clear, you can still reproduce this in today's Nightly?

Flags: needinfo?(me)

Checked it out on latest Nightly 71.0a1 (2019-09-08) (64-bit) on Windows 10 and it does appear now upon hovering on the video.
Ingvar, if by any chance, you still see this on latest Nightly, please let us know.

Closing it as resolved:wfm given that Bug 1548296 was already verified and also confirmed the Netflix fix.

Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(tbabos)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.