Closed Bug 1546786 Opened 1 year ago Closed 1 year ago

Rename Converting Guard CacheIR ops

Categories

(Core :: JavaScript Engine: JIT, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox70 --- fixed

People

(Reporter: mgaudet, Assigned: asorholm)

Details

Attachments

(1 file)

We have a number of CacheIR guards that are converting, in the sense that they return a new OperandId should the guard pass. For example, GuardIsBoolean returns an Int32OperandId indicating the boolean result of the input. This contrasts with ops like GuardIsNumber which takes a ValOperandId but doesn't return a new OperandId.

Having made a mistake on review by not recognizing one of these, I'd like to suggest that to highlight the converting nature of these, we rename them from GuardIsX to GuardToX; e.g. GuardIsBoolean becomes GuardToBoolean.

(It may also be worth at the same time marking the CacheIRWriter functions that produce these ops as MOZ_MUST_USE)

Jan: What do you think?

Flags: needinfo?(jdemooij)

Sounds great to me. Thanks!

Flags: needinfo?(jdemooij)
Priority: -- → P3
Assignee: nobody → asorholm
Keywords: checkin-needed

Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4d8a44b52bb6
Renames converting guard cacheIR ops. r=mgaudet

Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
You need to log in before you can comment on or make changes to this bug.