Closed Bug 1546793 Opened 1 year ago Closed 1 year ago

Build failure on Windows 10: libANGLE/renderer/d3d/d3d11/converged/CompositorNativeWindow11.h(15,10): fatal error: 'dispatcherqueue.h' file not found

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1546491

People

(Reporter: mconley, Unassigned)

References

(Blocks 1 open bug)

Details

I pulled from mozilla-central recently, and a clobber build after a ./mach bootstrap is giving me the following:

33:15.75 1 warning generated.
33:17.24 dom/canvas
33:17.32 gfx/angle/targets/libANGLE
33:20.41 js/src/jsapi-tests/jsapi-tests.exe
33:56.53 media/webrtc/trunk/gtest/webrtc-gtest.exe
34:02.83 toolkit/library/module.res
34:02.87 toolkit/library
34:03.43 Creating Resource file: module.res
34:05.61 toolkit/library/xul.dll
34:19.02 In file included from c:/Users/mconley/mozilla/mozilla-central/gfx/angle/checkout/src/libANGLE/renderer/d3d/d3d11/Renderer11.cpp:67:
34:19.05 c:/Users/mconley/mozilla/mozilla-central/gfx/angle/checkout/src\libANGLE/renderer/d3d/d3d11/converged/CompositorNativeWindow11.h(15,10): fatal error: 'dispatcherqueue.h' file not found
34:19.05 #include <dispatcherqueue.h>
34:19.05          ^~~~~~~~~~~~~~~~~~~
34:19.05 1 error generated.
34:19.09 mozmake.EXE[4]: *** [c:/Users/mconley/mozilla/mozilla-central/config/rules.mk:807: Renderer11.obj] Error 1
34:19.09 mozmake.EXE[4]: *** Waiting for unfinished jobs....
34:22.56 In file included from c:/Users/mconley/mozilla/mozilla-central/gfx/angle/checkout/src/libANGLE/renderer/d3d/d3d11/converged/CompositorNativeWindow11.cpp:10:
34:22.57 c:/Users/mconley/mozilla/mozilla-central/gfx/angle/checkout/src\libANGLE/renderer/d3d/d3d11/converged/CompositorNativeWindow11.h(15,10): fatal error: 'dispatcherqueue.h' file not found
34:22.57 #include <dispatcherqueue.h>
34:22.57          ^~~~~~~~~~~~~~~~~~~
34:22.57 1 error generated.
34:22.57 mozmake.EXE[4]: *** [c:/Users/mconley/mozilla/mozilla-central/config/rules.mk:805: CompositorNativeWindow11.obj] Error 1
34:23.43 mozmake.EXE[3]: *** [c:/Users/mconley/mozilla/mozilla-central/config/recurse.mk:74: gfx/angle/targets/libANGLE/target] Error 2
34:23.43 mozmake.EXE[3]: *** Waiting for unfinished jobs....
34:41.09 mozmake.EXE[2]: *** [c:/Users/mconley/mozilla/mozilla-central/config/recurse.mk:34: compile] Error 2
34:41.10 mozmake.EXE[1]: *** [c:/Users/mconley/mozilla/mozilla-central/config/rules.mk:400: default] Error 2
34:41.11 mozmake.EXE: *** [client.mk:125: build] Error 2
34:41.14 237 compiler warnings present.

I'm using mozilla-build 3.0.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1546491
You need to log in before you can comment on or make changes to this bug.