Closed Bug 1546959 Opened 5 months ago Closed 5 months ago

[File a new bug if this happens again] Intermittent TV browser_aboutPrefs_fc_patch_partialBadSize_completeBadSize.js | A promise chain failed to handle a rejection: BitsError {type: 39, action: 6, stage: 2, codeType: none} - stack: BitsError

Categories

(Toolkit :: Application Update, defect, P5)

Unspecified
Windows
defect

Tracking

()

RESOLVED DUPLICATE of bug 1546957

People

(Reporter: intermittent-bug-filer, Unassigned)

Details

(Keywords: intermittent-failure, regression)

#[markdown(off)]
Filed by: btara [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=242557774&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/H9vfXr0DQASrwsukXhwhkA/runs/0/artifacts/public/logs/live_backing.log

https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/H9vfXr0DQASrwsukXhwhkA/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1

12:27:16 INFO - TEST-START | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_partialBadSize_completeBadSize.js
12:27:16 INFO - GECKO(5692) | *** AUS:SVC Checker: checkForUpdates, force: true
12:27:16 INFO - GECKO(5692) | *** AUS:SVC UpdateService.canCheckForUpdates - able to check for updates
12:27:16 INFO - GECKO(5692) | *** AUS:SVC Checker:getUpdateURL - update URL: http://127.0.0.1:8888/browser/toolkit/mozapps/update/tests/browser/app_update.sjs?detailsURL=http://127.0.0.1:8888/&invalidPartialSize=1&invalidCompleteSize=1&appVersion=68.0a1&slowUpdateCheck=1&useSlowDownloadMar=1&force=1
12:27:16 INFO - GECKO(5692) | *** AUS:SVC Checker:checkForUpdates - sending request to: http://127.0.0.1:8888/browser/toolkit/mozapps/update/tests/browser/app_update.sjs?detailsURL=http://127.0.0.1:8888/&invalidPartialSize=1&invalidCompleteSize=1&appVersion=68.0a1&slowUpdateCheck=1&useSlowDownloadMar=1&force=1
12:27:17 INFO - GECKO(5692) | *** AUS:SVC Checker:onLoad - request completed downloading document
12:27:17 INFO - GECKO(5692) | *** AUS:SVC Checker:onLoad - Getting sslStatus failed.
12:27:17 INFO - GECKO(5692) | *** AUS:SVC Checker:onLoad - number of updates available: 1
12:27:17 INFO - GECKO(5692) | *** AUS:SVC isServiceInstalled - returning true
12:27:17 INFO - GECKO(5692) | *** AUS:SVC shouldUseService - returning false
12:27:17 INFO - GECKO(5692) | *** AUS:SVC getCanApplyUpdates - testing write access C:\ProgramData\Mozilla\updates\E226CB08649D95F1\update.test
12:27:17 INFO - GECKO(5692) | *** AUS:SVC getCanApplyUpdates - testing write access Z:\task_1556189360\build\application\firefox\update.test
12:27:17 INFO - GECKO(5692) | *** AUS:SVC getCanApplyUpdates - able to apply updates
12:27:17 INFO - GECKO(5692) | *** AUS:SVC Creating Downloader
12:27:17 INFO - GECKO(5692) | *** AUS:SVC UpdateService:_downloadUpdate
12:27:17 INFO - GECKO(5692) | *** AUS:SVC readStringFromFile - file doesn't exist: C:\ProgramData\Mozilla\updates\E226CB08649D95F1\updates\0\update.status
12:27:17 INFO - GECKO(5692) | *** AUS:SVC readStatusFile - status: null, path: C:\ProgramData\Mozilla\updates\E226CB08649D95F1\updates\0\update.status
12:27:17 INFO - GECKO(5692) | *** AUS:SVC getCanUseBits - BITS can be used to download updates
12:27:17 INFO - GECKO(5692) | *** AUS:SVC Downloader:_canUseBits - Patch is able to use BITS download
...
12:27:27 INFO - GECKO(5692) | *** AUS:SVC Downloader:onStopRequest - notifying observers of error. topic: update-error, status: download-attempt-failed
12:27:27 INFO - TEST-INFO | started process screenshot
12:27:27 INFO - TEST-INFO | screenshot: exit 0
12:27:27 INFO - Buffered messages logged at 12:27:16
12:27:27 INFO - Entering test bound setupTestCommon
12:27:27 INFO - Leaving test bound setupTestCommon
12:27:27 INFO - Entering test bound aboutPrefs_foregroundCheck_partialBadSize_completeBadSize
12:27:27 INFO - 12:27:16:512 | TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/update/tests/browser/shared.js | [setUpdateURL : 220] setting app.update.url to http://127.0.0.1:8888/browser/toolkit/mozapps/update/tests/browser/app_update.sjs?detailsURL=http://127.0.0.1:8888/&invalidPartialSize=1&invalidCompleteSize=1&appVersion=68.0a1&slowUpdateCheck=1&useSlowDownloadMar=1
12:27:27 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_partialBadSize_completeBadSize.js | The panel ID should equal checkingForUpdates - "checkingForUpdates" == "checkingForUpdates" -
12:27:27 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_partialBadSize_completeBadSize.js | There should not be an active update -
12:27:27 INFO - 12:27:16:979 | TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/update/tests/browser/head.js | [continueFileHandler : 134] Creating continue file, path: Z:\task_1556189360\build\tests\mochitest\browser\toolkit\mozapps\update\tests\browser\continueCheck
12:27:27 INFO - Buffered messages logged at 12:27:17
12:27:27 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_partialBadSize_completeBadSize.js | The panel ID should equal downloading - "downloading" == "downloading" -
12:27:27 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_partialBadSize_completeBadSize.js | There should be an active update -
12:27:27 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_partialBadSize_completeBadSize.js | The active update state should equal downloading -
12:27:27 INFO - 12:27:17:184 | TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/update/tests/browser/head.js | [continueFileHandler : 134] Creating continue file, path: Z:\task_1556189360\build\tests\mochitest\browser\toolkit\mozapps\update\tests\browser\continueDownload
12:27:27 INFO - Buffered messages logged at 12:27:22
12:27:27 INFO - Console message: [JavaScript Error: "Error: BitsError {type: 39, action: 6, stage: 2, codeType: none}" {file: "resource://gre/modules/Bits.jsm" line: 79}]
12:27:27 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_partialBadSize_completeBadSize.js | The patch property bitsResult value should equal 2147549183 -
12:27:27 INFO - 12:27:22:288 | TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/update/tests/browser/head.js | [continueFileHandler : 134] Creating continue file, path: Z:\task_1556189360\build\tests\mochitest\browser\toolkit\mozapps\update\tests\browser\continueDownload
12:27:27 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_partialBadSize_completeBadSize.js | The patch property internalResult value should equal 2147549183 -
12:27:27 INFO - 12:27:22:491 | TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/update/tests/browser/head.js | [continueFileHandler : 134] Creating continue file, path: Z:\task_1556189360\build\tests\mochitest\browser\toolkit\mozapps\update\tests\browser\continueDownload
12:27:27 INFO - Buffered messages logged at 12:27:27
12:27:27 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_partialBadSize_completeBadSize.js | The patch property bitsResult value should equal 2147549183 -
12:27:27 INFO - 12:27:27:600 | TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/update/tests/browser/head.js | [continueFileHandler : 134] Creating continue file, path: Z:\task_1556189360\build\tests\mochitest\browser\toolkit\mozapps\update\tests\browser\continueDownload
12:27:27 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_partialBadSize_completeBadSize.js | The panel ID should equal downloadFailed - "downloadFailed" == "downloadFailed" -
12:27:27 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_partialBadSize_completeBadSize.js | There should not be an active update -
12:27:27 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_partialBadSize_completeBadSize.js | The panel's link href should equal the expected value - "http://127.0.0.1:8888/" == "http://127.0.0.1:8888/" -
12:27:27 INFO - Buffered messages finished
12:27:27 INFO - TEST-UNEXPECTED-FAIL | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_partialBadSize_completeBadSize.js | A promise chain failed to handle a rejection: BitsError {type: 39, action: 6, stage: 2, codeType: none} - stack: BitsError@resource://gre/modules/Bits.jsm:79:5
12:27:27 INFO - failure@resource://gre/modules/Bits.jsm:151:21
12:27:27 INFO - cancelAsync/<@resource://gre/modules/Bits.jsm:288:21
12:27:27 INFO - requestPromise/<@resource://gre/modules/Bits.jsm:176:7
12:27:27 INFO - requestPromise@resource://gre/modules/Bits.jsm:140:10
12:27:27 INFO - cancelAsync@resource://gre/modules/Bits.jsm:287:12
12:27:27 INFO - Downloader_cancel@resource://gre/modules/UpdateService.jsm:3726:27
12:27:27 INFO - Downloader_onProgress@resource://gre/modules/UpdateService.jsm:4240:12
12:27:27 INFO - wrappedObserver_onProgress@resource://gre/modules/Bits.jsm:426:20
12:27:27 INFO - Rejection date: Thu Apr 25 2019 12:27:22 GMT+0000 (Greenwich Mean Time) - false == true - JS frame :: resource://testing-common/PromiseTestUtils.jsm :: assertNoUncaughtRejections :: line 257
12:27:27 INFO - Stack trace:
12:27:27 INFO - resource://testing-common/PromiseTestUtils.jsm:assertNoUncaughtRejections:257
12:27:27 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1140
12:27:27 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1144
12:27:27 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:1000
12:27:27 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
12:27:27 INFO - Leaving test bound aboutPrefs_foregroundCheck_partialBadSize_completeBadSize
12:27:27 INFO - GECKO(5692) | MEMORY STAT | vsize 730MB | vsizeMaxContiguous 518MB | residentFast 221MB | heapAllocated 94MB
12:27:27 INFO - TEST-OK | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_partialBadSize_completeBadSize.js | took 11385ms

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1546957
Summary: Intermittent TV toolkit/mozapps/update/tests/browser/browser_aboutPrefs_fc_patch_partialBadSize_completeBadSize.js | A promise chain failed to handle a rejection: BitsError {type: 39, action: 6, stage: 2, codeType: none} - stack: BitsError@resource://gre/ → [File a new bug if this happens again] Intermittent TV browser_aboutPrefs_fc_patch_partialBadSize_completeBadSize.js | A promise chain failed to handle a rejection: BitsError {type: 39, action: 6, stage: 2, codeType: none} - stack: BitsError
You need to log in before you can comment on or make changes to this bug.