div background loads on top of page instead of in div area

VERIFIED INVALID

Status

()

P3
normal
VERIFIED INVALID
17 years ago
14 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

({testcase})

Trunk
Future
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1a) Gecko/20020611
BuildID:    2002061104

The background of the div tag here loads stuck at the top of the page, instead
of in the <div> area. Also, if there are two different instances of a div tag
with a different background, the correct one displays in each, but both still
have the scrolling problem.

Reproducible: Always
Steps to Reproduce:
1. Go to page with example
 - Div tag has its own scrollbar, starts where scrollbar starts
2. Scroll down on page, until div section gets near top of page


Actual Results:  div background didn't display until div section was near top of
page

Expected Results:  The background should be stuck in the div section

I've had this problem with Mozilla in Linux, Windows XP, and windows 98. 

I saw similar bugs relating to tables, too.

Comment 1

17 years ago
I don't understand <div>, so I used the W3C validator, under strict XHTML1.0
(based on your logo at the bottom of the page, even though you're missing a
DOCTYPE declaration) and the validator complained about all sorts of things. I
would start fixing your XHTML bugs first.
(Reporter)

Comment 2

17 years ago
Actually, I'm using it as a sig on a messageboard, and so I had to put in extra
line breaks to make the page scroll. If you look, you'll see that every single
one of the errors is from one of those extra breaks. That's also the reason that
there's no declaration - I'm lazy, and didn't bother when I converted it to a
web page. The actual problem isn't with any of that stuff, though.

Also, I think the problem might just be that the browser is interpreting the
background-image:url(blahblah) as the background for the page, since if you
repeat it on x and y it shows, but acts as if the div area were a window, and as
you scroll the background stays fixed in the entire window, not the div area.
But if you put a background on the page, that shows up fine, and the div's
background still only shows up at the top...
Created attachment 90389 [details]
simplified testcase

I have narrowed this down to the style parameter "background-attachment: fixed"
of the DIV tag. If that one is ommitted, the page renders correctly. If that
parameter is used, the error occurs as described. (WinXP, Build 2002070608)
Correction: The testcase seems to show just one of the bugs, maybe the original
URL http://people.delphiforums.com/dolphinling/test3.html yields some more bugs.
Reporter: What do you think?

Now for the testcase: When scrolling, the background of the div is smeared. On
repaint, the background image is displayed correctly.

Changed state to NEW, added testcase keyword, set component to Image:GFX.
Status: UNCONFIRMED → NEW
Component: HTMLTables → Image: GFX
Ever confirmed: true
Keywords: testcase
Summary: div background loads on top of page instead of in div area → div background smears at scrolling

Updated

16 years ago
Priority: -- → P3
Target Milestone: --- → Future

Comment 5

16 years ago
mass reassign to default owner
Assignee: karnaze → table
Component: Image: GFX → Layout: Tables
QA Contact: amar → madhur
Target Milestone: Future → ---

Updated

16 years ago
Target Milestone: --- → Future
> Actual Results:  div background didn't display until div section was near top of
> page

This is the correct rendering.

> Expected Results:  The background should be stuck in the div section

That's what IE does with background-attachment:fixed.  It happens to be incorrect.

Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 7

14 years ago
Verifying and fixing the summary.
Status: RESOLVED → VERIFIED
Component: Layout: Tables → Layout: Block and Inline
Summary: div background smears at scrolling → div background loads on top of page instead of in div area
You need to log in before you can comment on or make changes to this bug.