Need to refresh icons on upgrade

VERIFIED FIXED in mozilla1.0.1

Status

SeaMonkey
Installer
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: Curt Patrick (gone), Assigned: Curt Patrick (gone))

Tracking

Trunk
mozilla1.0.1
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt1 RTM] [ETA 07/20])

Attachments

(5 attachments)

(Assignee)

Description

16 years ago
We discovered that new icons are not showing up on some systems when we upgrade
over old icons.  Sean has created a patch to fix this which I will attach.
(Assignee)

Comment 1

16 years ago
Created attachment 89472 [details] [diff] [review]
Mozilla Patch 1
(Assignee)

Comment 2

16 years ago
Created attachment 89473 [details] [diff] [review]
NS Patch 1
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 3

16 years ago
Comment on attachment 89472 [details] [diff] [review]
Mozilla Patch 1

Since this patch was created by ssu, I guess I can do the review.
r=curt
Attachment #89472 - Flags: review+
(Assignee)

Comment 4

16 years ago
Comment on attachment 89473 [details] [diff] [review]
NS Patch 1

r=curt
Attachment #89473 - Flags: review+
(Assignee)

Comment 5

16 years ago
Moving all cc list over from bugscape bug #16868.

Updated

16 years ago
Keywords: nsbeta1+
Whiteboard: [adt1 rtm]
(Assignee)

Comment 6

16 years ago
Comment on attachment 89472 [details] [diff] [review]
Mozilla Patch 1

Transfering this from the bugscape bug:
sr=dveditz
Attachment #89472 - Flags: superreview+
(Assignee)

Comment 7

16 years ago
Comment on attachment 89473 [details] [diff] [review]
NS Patch 1

Transfering this from the bugscape bug:
sr=dveditz
Attachment #89473 - Flags: superreview+
(Assignee)

Updated

16 years ago
Keywords: adt1.0.1

Comment 8

16 years ago
Adding adt1.0.1+ on behalf of the adt for checkin to the 1.0 branch.  When you
check this into the branch, please change the mozilla1.0.1+ keyword to fixed1.0.1
Keywords: adt1.0.1 → adt1.0.1+

Updated

16 years ago
Blocks: 143047
Keywords: approval, mozilla1.0.1
Whiteboard: [adt1 rtm] → [adt1 rtm] [ETA 07/01]
Target Milestone: --- → mozilla1.0.1

Updated

16 years ago
Attachment #89472 - Flags: approval+

Comment 9

16 years ago
please checkin to the 1.0.1 branch. once there, remove the "mozilla1.0.1+"
keyword and add the "fixed1.0.1" keyword.
Keywords: mozilla1.0.1 → mozilla1.0.1+
(Assignee)

Comment 10

16 years ago
Checked in to trunk and branch for both mozilla and ns.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Keywords: adt1.0.1+, mozilla1.0.1+ → fixed1.0.1
Resolution: --- → FIXED
Whiteboard: [adt1 rtm] [ETA 07/01] → [adt1 rtm]

Comment 11

16 years ago
verified on branch 2002070108
trunk 2002070204
Status: RESOLVED → VERIFIED
Keywords: fixed1.0.1 → verified1.0.1
QA Contact: bugzilla → gbush
Evelyn is reporting that this is not fixed yet.  We may need to reopen.  Grace -
can you follow up with Evelyn?

Comment 13

16 years ago
I'm using yesterday's branch build and run Win2k.  My Mail and IM desktop icons
are still the "older" square ones, which I believe are outdated.  I did not
uninstall the previous build before installing yesterday's.  I did a Recommended
install.

Comment 14

16 years ago
removing verified1.0.1 to reopen the bug on the branch based on Evelyn's
comments (and others who have mentioned the same thing).  If this also hapepns
on the branch, please reopen the bug.
Keywords: verified1.0.1

Comment 15

16 years ago
Evelyn,

Can I come by and see what is happening on your machine?  I cannot reproduce
this on my 2k machine.

Comment 16

16 years ago
Reopening because of problems on win2k
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 17

16 years ago
I have a Win 2K machine that I just updated for the first time in a few months.
 The mail and IM icons didn't refresh for me either.  The browser icon worked fine.

Comment 18

16 years ago
not able to reproduce now- saw what was happening on Evelyn's machine- Browser 
icon gets updated but not Mail or IM. 
I tried to reinstall PR1, but get the new icons each for Mail and IM each  time 
I do get the old Browser icon.  
If you're still getting the new icons when you install the old build then you do
have the problem, and you'll have to clear it before you can test the upgrade
again. ssu attached a little utility to one of these bugs (or maybe mail) that
will do it, or you can find TweakUI and clear it.

The difference between the executable and everything else is that the executable
contains an icon internally while the others reference separate .ico files. The
caching appears to handle those cases differently.

Comment 20

16 years ago
Created attachment 91011 [details]
UpdateIcon.exe - utility to refresh desktop icons under Win2k and WinXP

Comment 21

16 years ago
by the way, my patch in bug 155025 *does* work for .exe files and shortcuts, but
only under Win2k.  That patch does not work under WinXP.

Comment 22

16 years ago
Created attachment 91015 [details]
UpdateIcon2.exe - utility to refresh icons. does not work under WinXP, only Win2k

This .exe uses the patch in bug 155025 to refresh the desktop icons.  It works
under Win2k, but not WinXP.

Comment 23

16 years ago
I rebooted my Win2K machine for the first time since I installed the build with
the new icons.  Now the icons are correct.
(Assignee)

Comment 24

16 years ago
Created attachment 91450 [details] [diff] [review]
Mozilla Patch 2

Since the new functionality is sorting icons we need to turn it off for
mozilla.  Mozilla is not dependant upon this funtionality at this time, and
Netscape came up with an install script solution that has not impact on
mozilla.
Comment on attachment 91450 [details] [diff] [review]
Mozilla Patch 2

sr=dveditz

Shouldn't we eventually back out the code that didn't work instead?
Attachment #91450 - Flags: superreview+

Comment 26

16 years ago
Comment on attachment 91450 [details] [diff] [review]
Mozilla Patch 2

r=ssu

I think it's safer this way for right now (less change).  Perhaps removing it
on the trunk is best, but not on the branch.
Attachment #91450 - Flags: review+
(Assignee)

Comment 27

16 years ago
I created bug #157666 to remind us to back the obsolete code out.

Updated

16 years ago
Keywords: adt1.0.1, mozilla1.0.1
Whiteboard: [adt1 rtm] → [adt1 rtm] [ETA 07/17]

Comment 28

16 years ago
I just wanted to verify that if this gets checked in the Netscape build will
still do what want it to?
It's currently *not* doing what we want it to, this latest change at least stops
it from doing what we DON'T want it to. There's another bug (bugscape) that gets
the effect you're after in commercial.

Comment 30

16 years ago
It sounds like this doesn't affect the ns build since bugscape 16868 covers the
work for that.  So I'm removing mach v tracking kewyords.
Keywords: nsbeta1+
Whiteboard: [adt1 rtm] [ETA 07/17] → [ETA 07/17]

Comment 31

16 years ago
Comment on attachment 91450 [details] [diff] [review]
Mozilla Patch 2

a=asa (on behalf of drivers) for checkin to 1.1
Attachment #91450 - Flags: approval+
(Assignee)

Comment 32

16 years ago
Checked in to mozilla trunk.  Can I close this, or does this need to be checked
in to MOZILLA_1_0_BRANCH?  I'm not clear on that.

Comment 33

16 years ago
you can close this bug as fixed if the patch has been checked into the trunk.

Add keyword fixed1.0.1 when checked into the branch.
(Assignee)

Comment 34

16 years ago
Duh.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED

Comment 35

16 years ago
has this been checked into the 1.0 branch? if not, we need to get it in asap.

gbush: can you verify this on the trunk?
Whiteboard: [ETA 07/17] → [adt1 RTM] [ETA 07/20]

Comment 36

16 years ago
Please get this into the branch. Added adt1.0.1+
Keywords: adt1.0.1 → adt1.0.1+

Comment 37

16 years ago
verified trunk 2002071908
Status: RESOLVED → VERIFIED

Comment 38

16 years ago
a=chofmann for the 1.0.1 branch as well
Keywords: mozilla1.0.1 → mozilla1.0.1+
(Assignee)

Comment 39

16 years ago
Checked in to 1.0.1 branch
Keywords: adt1.0.1+, mozilla1.0.1+ → fixed1.0.1

Comment 40

16 years ago
branch build 2002072308 on Win 2k machine
Keywords: fixed1.0.1 → verified1.0.1
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.