Japanese EUC-JP characters are displayed garbled in Message source

RESOLVED DUPLICATE of bug 1017768

Status

MailNews Core
Internationalization
--
minor
RESOLVED DUPLICATE of bug 1017768
16 years ago
3 years ago

People

(Reporter: Yuying Long, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

2.39 KB, application/octet-stream
Details
(Reporter)

Description

16 years ago
Build: 06-27 1.0.0 branch build / WinXP-SC.

Steps:
1. a. Create a Japanese EUC-jp mail.
   b. Create an iso-8859-1 email with EUC-JP attachment (text or html file).
2. Send the mail and open in the mail body.

Result:
You will see the Japanese characters in mail body are displayed properly
(manually correct charset or turn on auto-detection if neccessary), however,
when open Message Source, those Japanese characters are displayed garbled.

Note: for shift-jis or gb2312 mail doesn't has the same problem.

Comment 1

16 years ago
>Create a Japanese EUC-jp mail.
How did you create it? EUC-JP is not in the mail compose charset menu.

Bug 40613 is about page source problem.

Comment 2

16 years ago
looks like a dup of 40613

Comment 3

16 years ago
I looked at this with Yuying yesterday. It looks like euc-jp attachment has this
problem. It's not about the mail body. to reproduce it:
1. Compose a latin-1 mail but with a euc-jp text attachment.
2. After mail is received, the attachment is displayed garbled as expected since
it doesn't have charset meta-tag.
3. Correct the display either by selecting euc-jp menu or turning on
auto-detector to Japanese.
4. Open message source after mail diplay is corrected.

I think there are two problems here:
1. charset manually selected from charset menu or sniffed from auto-detector is
not carried over to message source window. (we may have a bug on this already?)
2. In case auto-detector is turned on ( correct the view by turning on
auto-detector at step 3), auto-detector is not working for euc attachment in
message source window.

Updated

16 years ago
Status: NEW → ASSIGNED

Comment 4

15 years ago
Created attachment 104980 [details]
possible test case

possible test case

this EUC email is sent as a block, and is not displayed by mozilla correcrly,
could someone tell me if its related or should be filed as a separate bug
please

regards
JG

Comment 5

15 years ago
add JG
Product: MailNews → Core
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
QA Contact: marina → i18n
reproduce on 3.1
Assignee: nhottanscp → nobody
Severity: normal → minor
Status: ASSIGNED → NEW
OS: Windows XP → All
Hardware: x86 → All
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1017768
You need to log in before you can comment on or make changes to this bug.