Site displays source codes or displays items twice or other strange layout issues

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
17 years ago
14 years ago

People

(Reporter: indnsfan41, Assigned: Matti)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1a+) Gecko/20020622
BuildID:    2002062208

When looknig at ameritrades website, all kinds of information about the page
loads that shouldnt.  sometimes tables are displayed twice, or things dont load
at all

Reproducible: Always
Steps to Reproduce:
1. log into ameritrade
2. click account status

Actual Results:  items dont appear, source code is shown, serveral issues with
layout.  refreshing sometimes fixes a few of these but not all

Expected Results:  the page should of displayed with out issues

I relize not everyone has an ameritrade account, so i will try to make a
testcase and provide all the information i have, also please let me know what
other information you need.
(Assignee)

Comment 1

17 years ago
Is the full page displayed as source ?
Or only a frame ?

If full page or frame (load this frame in a new single window) and type this in
the URL bar :
javascript:alert(document.contentType)

What do you get ?
(Reporter)

Comment 2

17 years ago
sometimes i get an entire frame as source, others it is some source and some of
what should be displayed.

looking at it today i got the "stock order entry" frame as the following

---------------------------------------------------------------

//function assigns the symbol value of the order ticket form to the quote form
//and if the value of the form is not null then it changes the form action to
the //results page. This was done this way so if someone as javascript turned
off they will // go to the normal get a quote page function do_Submit_Quotes() {
document.quoteForm.symbol.value = document.ADVANCEDORDER.symbol.value; if
(document.quoteForm.symbol.value.length > 0) {
document.quoteForm.action="/cgi-bin/apps/QuoteResult"
document.quoteForm.submit(); } else return false; } var popup; function
popbrowser(URL) { var popup; if (popup != null && !popup.closed) {
popup.close(); }
popup=window.open(URL,"offsite","WIDTH=700,HEIGHT=350,resizable=1,scrollbars=1,status=1,toolbar=1");
} function pophelpcenter(URL) { var help_center; if (help_center != null &&
!help_center.closed) { help_center.close(); } help_center = window.open
(URL,'HelpCenter','width=520,height=520,resizable=yes,scrollbars=yes'); } var
message_window; function popmessage(URL) { //Message Popup if (message_window !=
null && !message_window.closed) { message_w

---------------------------------------------------------------

Opening this frame in a new window, and it displayed correctly.  
typing "javascript:alert(document.contentType)" gives me a popup box with Text\HTML

Other problems that some times occur are that text doesnt look like it was
formatted like the rest of the page (css issue?), and sometimes images or text
appear twice or in the wrong frame, other times not at all.

This also occurs on windows 2000
(Assignee)

Comment 3

17 years ago
Can you save the page, remove all personal informations and attach it to this bug ?
(if you can reproduce it with the source)


CC dbradley@netscape.com because he has an account there (see bug 99511)
(Reporter)

Comment 4

17 years ago
Created attachment 89577 [details]
What i see (double tables, source code...)
(Reporter)

Comment 5

17 years ago
Here is one of the frames from the site's page.  I have removed all the links,
and information about my account.  There are other frames with similar problems
but have more personal information i will have to remove.  

Reloading corrects most of the display problems most of the time but not always.
 Also see this on 2002062804

One Attachment is what i see, and the other is what it should look like, for
some reason after saving these pages the "shadow" under the frame was enlarged,
i didnt see this when i am looking at the real site.  (I think this is because
of a spacer.gif that i did not download, and having that image in the table
would make it the correct size)

I am also including the css file

You can see that "welcome message" table is displayed twice, and there are bits
of source code all over the page.  Reloading the file i saved locally doesnt fix
the problem
(Reporter)

Comment 6

17 years ago
Created attachment 89578 [details]
What the page should look like
(Reporter)

Comment 7

17 years ago
Created attachment 89579 [details]
The css for the page

Comment 8

16 years ago
Mike, is this still a problem using mozilla 1.1?  
(Reporter)

Comment 9

16 years ago
I haven't seen this in a while, Im using the nightlies (currentally 
200291110), i dont know if this is a duplicate of another bug, and it was 
fixed, or if ameritrade changed the coding on the website, either way its 
fixed.  Marking Fixed due to other checkin or this was evangelism...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 10

16 years ago
.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 11

16 years ago
Resolving WFM.  FIXED should only be used for bugs that have patches checked
into the tree.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.