Closed Bug 1547195 Opened 3 years ago Closed 3 years ago

Categories

(Firefox for Android Graveyard :: First Run, defect, P5)

defect

Tracking

(firefox68 fixed)

RESOLVED FIXED
Firefox 68
Tracking Status
firefox68 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: petru, NeedInfo)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [stockwell fixed:product])

Attachments

(1 file)

#[markdown(off)]
Filed by: apavel [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=242818280&repo=autoland

https://queue.taskcluster.net/v1/task/ZVClCg_eQX2NfU2B7w0Dog/runs/0/artifacts/public/logs/live_backing.log

[task 2019-04-26T08:24:31.811Z] 08:24:31 INFO - > Task :app:lintWithoutGeckoBinariesDebug FAILED
[task 2019-04-26T08:24:31.910Z] 08:24:31 INFO - FAILURE: Build failed with an exception.
[task 2019-04-26T08:24:31.910Z] 08:24:31 INFO - * What went wrong:
[task 2019-04-26T08:24:31.910Z] 08:24:31 INFO - Execution failed for task ':app:lintWithoutGeckoBinariesDebug'.
[task 2019-04-26T08:24:31.911Z] 08:24:31 INFO - > Lint found errors in the project; aborting build.
[task 2019-04-26T08:24:31.911Z] 08:24:31 INFO - Fix the issues identified by lint, or add the following to your build script to proceed with errors:
[task 2019-04-26T08:24:31.911Z] 08:24:31 INFO - ...
[task 2019-04-26T08:24:31.911Z] 08:24:31 INFO - android {
[task 2019-04-26T08:24:31.911Z] 08:24:31 INFO - lintOptions {
[task 2019-04-26T08:24:31.911Z] 08:24:31 INFO - abortOnError false
[task 2019-04-26T08:24:31.911Z] 08:24:31 INFO - }
[task 2019-04-26T08:24:31.911Z] 08:24:31 INFO - }
[task 2019-04-26T08:24:31.911Z] 08:24:31 INFO - ...
[task 2019-04-26T08:24:31.912Z] 08:24:31 INFO - Errors found:
[task 2019-04-26T08:24:31.912Z] 08:24:31 INFO - /builds/worker/workspace/build/src/mobile/android/app/src/main/res/drawable-nodpi/firstrun_complete.png: Error: The resource R.drawable.firstrun_complete appears to be unused [UnusedResources]
[task 2019-04-26T08:24:31.912Z] 08:24:31 INFO - * Try:
[task 2019-04-26T08:24:31.912Z] 08:24:31 INFO - Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
[task 2019-04-26T08:24:31.913Z] 08:24:31 INFO - * Get more help at https://help.gradle.org
[task 2019-04-26T08:24:31.913Z] 08:24:31 INFO - Deprecated Gradle features were used in this build, making it incompatible with Gradle 5.0.
[task 2019-04-26T08:24:31.913Z] 08:24:31 INFO - Use '--warning-mode all' to show the individual deprecation warnings.
[task 2019-04-26T08:24:31.913Z] 08:24:31 INFO - See https://docs.gradle.org/4.10.2/userguide/command_line_interface.html#sec:command_line_warnings
[task 2019-04-26T08:24:31.913Z] 08:24:31 INFO - BUILD FAILED in 51s
[task 2019-04-26T08:24:31.913Z] 08:24:31 INFO - 47 actionable tasks: 1 executed, 46 up-to-date
[task 2019-04-26T08:24:32.493Z] 08:24:32 INFO - TinderboxPrint: report<br/><a href="https://queue.taskcluster.net/v1/task/ZVClCg_eQX2NfU2B7w0Dog/runs/0/artifacts/public/android/lint/lint-results-withoutGeckoBinariesDebug.html">HTML withoutGeckoBinariesDebug report</a>, visit "Inspect Task" link for details
[task 2019-04-26T08:24:32.493Z] 08:24:32 INFO - TinderboxPrint: report<br/><a href="https://queue.taskcluster.net/v1/task/ZVClCg_eQX2NfU2B7w0Dog/runs/0/artifacts/public/android/lint/lint-results-withoutGeckoBinariesDebug.xml">XML withoutGeckoBinariesDebug report</a>, visit "Inspect Task" link for details
[task 2019-04-26T08:24:32.493Z] 08:24:32 INFO - TEST-UNEXPECTED-FAIL | android-lint | Lint found errors in the project; aborting build. See the report at: https://queue.taskcluster.net/v1/task/ZVClCg_eQX2NfU2B7w0Dog/runs/0/artifacts/public/android/lint/lint-results-withoutGeckoBinariesDebug.html
[task 2019-04-26T08:24:32.493Z] 08:24:32 INFO - SUITE-START | android-lint | withoutGeckoBinariesDebug
[task 2019-04-26T08:24:32.494Z] 08:24:32 INFO - TEST-UNEXPECTED-FAIL | <issue category="Performance" explanation="Unused resources make applications larger and slow down builds." id="UnusedResources" message="The resource `R.drawable.firstrun_complete` appears to be unused" priority="3" quickfix="studio" severity="Error" summary="Unused resources">
[task 2019-04-26T08:24:32.494Z] 08:24:32 INFO - TEST-UNEXPECTED-FAIL | <location file="/builds/worker/workspace/build/src/mobile/android/app/src/main/res/drawable-nodpi/firstrun_complete.png" />
[task 2019-04-26T08:24:32.494Z] 08:24:32 INFO - TEST-UNEXPECTED-FAIL | </issue>
[task 2019-04-26T08:24:32.494Z] 08:24:32 INFO - SUITE-END | android-lint | withoutGeckoBinariesDebug
[task 2019-04-26T08:24:32.512Z] 08:24:32 ERROR - Return code: 1
[task 2019-04-26T08:24:32.512Z] 08:24:32 ERROR - 1 not in success codes: [0]
[task 2019-04-26T08:24:32.512Z] 08:24:32 WARNING - setting return code to 2
[task 2019-04-26T08:24:32.512Z] 08:24:32 FATAL - Halting on failure while running ['/builds/worker/workspace/build/src/obj-x86_64-pc-linux-gnu/_virtualenvs/init/bin/python', 'mach', '--log-no-times', 'android', 'lint']
[task 2019-04-26T08:24:32.512Z] 08:24:32 FATAL - Running post_fatal callback...
[task 2019-04-26T08:24:32.512Z] 08:24:32 FATAL - Exiting 2

James please take a look at this.

Flags: needinfo?(snorp)

This is Fennec stuff. -> stefan

Flags: needinfo?(snorp) → needinfo?(sarentz)
Summary: Intermittent android-lint | Lint found errors in the project; aborting build. See the report at: https://queue.taskcluster.net/v1/task/ZVClCg_eQX2NfU2B7w0Dog/runs/0/artifacts/public/android/lint/lint-results-withoutGeckoBinariesDebug.html → Perma android-lint | Lint found errors in the project; aborting build. See the report at: https://queue.taskcluster.net/v1/task/ZVClCg_eQX2NfU2B7w0Dog/runs/0/artifacts/public/android/lint/lint-results-withoutGeckoBinariesDebug.html
Has Regression Range: --- → yes

There are 40 total failures in the last 7 days on android-4-0-armv7-api16 opt: https://treeherder.mozilla.org/intermittent-failures.html#/bugdetails?startday=2019-04-27&endday=2019-05-04&tree=trunk&bug=1547195

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=244598855&repo=mozilla-inbound&lineNumber=2948

[task 2019-05-03T22:23:38.027Z] 22:23:38 INFO - TEST-UNEXPECTED-FAIL | android-lint | Lint found errors in the project; aborting build. See the report at: https://queue.taskcluster.net/v1/task/EC6FPAj0Qz21dzorxeo4AA/runs/0/artifacts/public/android/lint/lint-results-withoutGeckoBinariesDebug.html
[task 2019-05-03T22:23:38.027Z] 22:23:38 INFO - SUITE-START | android-lint | withoutGeckoBinariesDebug
[task 2019-05-03T22:23:38.028Z] 22:23:38 INFO - TEST-UNEXPECTED-FAIL | <issue category="Performance" explanation="Unused resources make applications larger and slow down builds." id="UnusedResources" message="The resource R.drawable.firstrun_complete appears to be unused" priority="3" quickfix="studio" severity="Error" summary="Unused resources">
[task 2019-05-03T22:23:38.028Z] 22:23:38 INFO - TEST-UNEXPECTED-FAIL | <location file="/builds/worker/workspace/build/src/mobile/android/app/src/main/res/drawable-nodpi/firstrun_complete.png" />
[task 2019-05-03T22:23:38.028Z] 22:23:38 INFO - TEST-UNEXPECTED-FAIL | </issue>
[task 2019-05-03T22:23:38.028Z] 22:23:38 INFO - SUITE-END | android-lint | withoutGeckoBinariesDebug
[task 2019-05-03T22:23:38.049Z] 22:23:38 ERROR - Return code: 1
[task 2019-05-03T22:23:38.049Z] 22:23:38 ERROR - 1 not in success codes: [0]
[task 2019-05-03T22:23:38.049Z] 22:23:38 WARNING - setting return code to 2
[task 2019-05-03T22:23:38.049Z] 22:23:38 FATAL - Halting on failure while running ['/builds/worker/workspace/build/src/obj-x86_64-pc-linux-gnu/_virtualenvs/init/bin/python', 'mach', '--log-no-times', 'android', 'lint']
[task 2019-05-03T22:23:38.049Z] 22:23:38 FATAL - Running post_fatal callback...
[task 2019-05-03T22:23:38.049Z] 22:23:38 FATAL - Exiting 2
[task 2019-05-03T22:23:38.050Z] 22:23:38 INFO - [mozharness: 2019-05-03 22:23:38.049970Z] Finished build step (failed)
[task 2019-05-03T22:23:38.050Z] 22:23:38 INFO - Running post-run listener: _parse_build_tests_ccov
[task 2019-05-03T22:23:38.050Z] 22:23:38 INFO - Running post-run listener: _shutdown_sccache
[task 2019-05-03T22:23:38.050Z] 22:23:38 INFO - Running post-run listener: _summarize
[task 2019-05-03T22:23:38.050Z] 22:23:38 ERROR - # TBPL FAILURE #
[task 2019-05-03T22:23:38.050Z] 22:23:38 INFO - [mozharness: 2019-05-03 22:23:38.050201Z] FxDesktopBuild summary:
[task 2019-05-03T22:23:38.050Z] 22:23:38 ERROR - # TBPL FAILURE #
[taskcluster 2019-05-03 22:23:38.465Z] === Task Finished ===
[taskcluster 2019-05-03 22:23:38.633Z] Artifact "public/android/lint/lint-results-officialWithoutGeckoBinariesDebug.xml" not found at "/builds/worker/workspace/build/src/obj-firefox/gradle/build/mobile/android/app/reports/lint-results-officialWithoutGeckoBinariesDebug.xml"
[taskcluster 2019-05-03 22:23:38.729Z] Artifact "public/android/lint/lint-results-officialWithoutGeckoBinariesDebug_files" not found at "/builds/worker/workspace/build/src/obj-firefox/gradle/build/mobile/android/app/reports/lint-results-officialWithoutGeckoBinariesDebug_files"
[taskcluster 2019-05-03 22:23:38.833Z] Artifact "public/android/lint/lint-results-officialWithoutGeckoBinariesDebug.html" not found at "/builds/worker/workspace/build/src/obj-firefox/gradle/build/mobile/android/app/reports/lint-results-officialWithoutGeckoBinariesDebug.html"
[taskcluster 2019-05-03 22:23:39.454Z] Unsuccessful task run with exit code: 2 completed in 858.298 seconds

Whiteboard: [stockwell needswork:owner]
Assignee: nobody → petru.lingurar
Status: NEW → ASSIGNED
Flags: needinfo?(petru.lingurar)

Bryan, will we use the firstrun_complete from bug 1545805 comment 6 for anything?
Currently only the firstrun_welcome, firstrun_sync and firstrun_secure images are used because the new Onboarding only has 3 screens.

Flags: needinfo?(sarentz) → needinfo?(bbell)

This image was initially parts of the new Onboarding UX assets but
it is unused at the moment.

Went with removing the asset for now. If it is to be used in the future we can add it then.

Keywords: checkin-needed
Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Whiteboard: [stockwell unknown] → [stockwell fixed:product]
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.