[File a new bug if this happens again] Intermittent browser_aboutDialog_fc_patch_completeBadSize.js | A promise chain failed to handle a rejection: BitsError {type: 39, action: 6, stage: 2, codeType: none} - stack: BitsError

RESOLVED DUPLICATE of bug 1546957

Status

()

defect
P5
normal
RESOLVED DUPLICATE of bug 1546957
4 months ago
3 months ago

People

(Reporter: intermittent-bug-filer, Unassigned)

Tracking

({intermittent-failure, regression})

Firefox Tracking Flags

(Not tracked)

Details

#[markdown(off)]
Filed by: rmaries [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=242846796&repo=mozilla-central

https://queue.taskcluster.net/v1/task/RYRYH-NMTuCM0SGPZhSmow/runs/0/artifacts/public/logs/live_backing.log

12:44:12 INFO - TEST-START | toolkit/mozapps/update/tests/browser/browser_aboutDialog_fc_patch_completeBadSize.js
12:44:19 INFO - TEST-UNEXPECTED-FAIL | toolkit/mozapps/update/tests/browser/browser_aboutDialog_fc_patch_completeBadSize.js | A promise chain failed to handle a rejection: BitsError {type: 39, action: 6, stage: 2, codeType: none} - stack: BitsError@resource://gre/modules/Bits.jsm:79:5
12:44:19 INFO - failure@resource://gre/modules/Bits.jsm:151:21
12:44:19 INFO - cancelAsync/<@resource://gre/modules/Bits.jsm:288:21
12:44:19 INFO - requestPromise/<@resource://gre/modules/Bits.jsm:176:7
12:44:19 INFO - requestPromise@resource://gre/modules/Bits.jsm:140:10
12:44:19 INFO - cancelAsync@resource://gre/modules/Bits.jsm:287:12
12:44:19 INFO - Downloader_cancel@resource://gre/modules/UpdateService.jsm:3728:27
12:44:19 INFO - Downloader_onProgress@resource://gre/modules/UpdateService.jsm:4249:12
12:44:19 INFO - wrappedObserver_onProgress@resource://gre/modules/Bits.jsm:426:20
12:44:19 INFO - Rejection date: Fri Apr 26 2019 12:44:18 GMT+0000 (Greenwich Mean Time) - false == true - JS frame :: resource://testing-common/PromiseTestUtils.jsm :: assertNoUncaughtRejections :: line 257
12:44:19 INFO - Stack trace:
12:44:19 INFO - resource://testing-common/PromiseTestUtils.jsm:assertNoUncaughtRejections:257
12:44:19 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1140
12:44:19 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1144
12:44:19 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:1005
12:44:19 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
12:44:19 INFO - Leaving test bound aboutDialog_foregroundCheck_completeBadSize
12:44:19 INFO - GECKO(6596) | MEMORY STAT | vsize 6971MB | vsizeMaxContiguous 68068712MB | residentFast 240MB | heapAllocated 90MB

OS: Unspecified → Windows
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1546957
Summary: Intermittent toolkit/mozapps/update/tests/browser/browser_aboutDialog_fc_patch_completeBadSize.js | A promise chain failed to handle a rejection: BitsError {type: 39, action: 6, stage: 2, codeType: none} - stack: BitsError@resource://gre/modules/Bits.jsm → [File a new bug if this happens again] Intermittent browser_aboutDialog_fc_patch_completeBadSize.js | A promise chain failed to handle a rejection: BitsError {type: 39, action: 6, stage: 2, codeType: none} - stack: BitsError
You need to log in before you can comment on or make changes to this bug.