Closed Bug 1547459 Opened 7 months ago Closed 6 months ago

[UX] Do not show cross for new "span" background image option

Categories

(Firefox :: Shell Integration, defect)

68 Branch
Desktop
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 68
Tracking Status
firefox68 --- fixed

People

(Reporter: c4609174, Assigned: Kwan, NeedInfo)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

As per Firefox Nightlie's Twitter announcement: https://twitter.com/FirefoxNightly/status/1121047080368209926

Go to an image -> right-click -> set background image -> "span"

Actual results:

There is a huge red cross displayed in the preview. IMHO, this is a UX issue.

Because, at least I, thought this meant it did not work. Only later I noticed that it does not actually prevent me from clicking the confirm button/setting the image.


Another issue is, that one obviously cannot understand what "span" actually does/means, especially when you have no useful preview. The replies to the Twitter thread also showed this.

I.e. the user is just confused by the current UI.

Expected results:

Maybe display a better image instead with multiple screens?

Or, at least, display some arrows or so in the preview that indicate it is "spanned" across multiple screens.

A cross is an indicator for error or "not available" or similar. That should not be used here.

Component: Untriaged → Shell Integration
Depends on: 612373
OS: Unspecified → Linux
Hardware: Unspecified → Desktop

From what I understand the problem is that the OS determines how to split/span the image, and that will depend on your OS and display setup. We don't know that setup, certainly not on Linux, so we can't ever produce an accurate preview image.

I'm not aware of the web having primitives to split an image automatically here - I guess we could source the image twice and use regions to only display part of it, but then it'll still be confusing for people with 3 or more screens (plus we have no idea what the ordering/organizing of the screens is). It's all a bit of a mess... I'm happy to hear suggestions. Perhaps Stephen has an idea?

Flags: needinfo?(shorlander)

Yeah, just show a different icon. I guess it's not worth the need to (try to) detect how many screens the user has, or similar.

It's just currently a bad UX, as you have no idea what the option does and the cross may lead you to think this is an error.

When I implemented the no preview for span I did originally try using text in
the canvas, but discarded it when I realised trying to format it to display
nicely (across different languages and text lengths) was a losing proposition.
However just the prohibition symbol without context is confusing to users, and
on reflection the text can easily be included as an element stacked on top of
the canvas.

Also lighten the background of the no preview message, since the pure black was
indistinguishable from the frame sides on Windows and Linux.

See Also: → 1538988
Assignee: nobody → moz-ian
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

I've started reviewing the patch and code-wise it looks fine. I want to double-check some of the new edge cases we get now that we're using text here though - like legibility in high-contrast and dark mode and with large fonts. Sorry for the delay, if you want to check those I can stamp this later today, otherwise I'll pick it back up on monday.

Flags: needinfo?(moz-ian)

I'm more than happy to wait for someone other than me to check edge cases :)

Flags: needinfo?(moz-ian)
See Also: → 1549537
Attachment #9062341 - Attachment description: Bug 1547459 - Use explicit text for desktop span preview not being available. r=jaws → Bug 1547459 - Use explicit text for desktop span preview not being available.
Pushed by ccoroiu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c22a9760c9eb
Use explicit text for desktop span preview not being available. r=sfoster
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
You need to log in before you can comment on or make changes to this bug.