Closed Bug 1547596 Opened 4 months ago Closed 4 months ago

Crash in mozilla::DataStorage::Remove

Categories

(Core :: Networking: HTTP, defect, critical)

68 Branch
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- unaffected
firefox68 blocking fixed

People

(Reporter: zombulla14, Unassigned)

References

(Regression)

Details

(Keywords: crash, regression, topcrash)

Crash Data

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

Since the 28042019 nightly, there was a top crasher introduced in mozilla::DataStorage::Remove

I get an instant browser crash as soon as I visit http://cyfostreams.com/
other users on http://forums.mozillazine.org/viewtopic.php?f=23&t=3049563&p=14830603 get the crash when accessing ipchicken.com

According to the crashes report, this seems like a last day introduced top crasher.
https://crash-stats.mozilla.org/topcrashers/?product=Firefox&version=68.0a1&days=1

Happens both in normal mode & safe mode

Some crash reports :
https://crash-stats.mozilla.org/report/index/6d1e612e-30ed-4d06-85af-ce3870190428
https://crash-stats.mozilla.org/report/index/0be4b558-7cae-4e7a-9cf9-b902c0190428
https://crash-stats.mozilla.org/report/index/99c54b8c-3932-4cd8-ab83-2d38a0190428
https://crash-stats.mozilla.org/report/index/472b95f2-c338-49ed-999b-4041c0190428

Actual results:

Crashes as soon as specific sites are visited (or are restored after browser restart)

Expected results:

Should not have happened.

these crash reports come with MOZ_CRASH(given bad DataStorage storage type) and appear to be regressing with the changes from bug 1535697.

Severity: normal → critical
Crash Signature: [@ mozilla::DataStorage::Remove ]
Component: Untriaged → Networking: HTTP
Product: Firefox → Core
Regressed by: 1535697
Status: UNCONFIRMED → NEW
Ever confirmed: true

I cannot crash with new profile.
However, I can reproduce the crash when simulate upgrade to Nightly68 from Firefox67.0b14.

100% Reproducible Steps To Reproduce:

  1. Start Firefox 67.0b14 with NEW CREATED PROFILE

  2. Open http://cyfostreams.com/

  3. Quit the browser

  4. Start Latest Nightly 68.0a1(20190428094048) with THE SAME PROFILE of step 1 (i.e, simulate upgrade to Nightly68 from Firefox67.0b14)

  5. Open http://cyfostreams.com/

Actual Results:
Browser Crashes

Duplicate of this bug: 1547600
Crash Signature: [@ mozilla::DataStorage::Remove ] → [@ mozilla::DataStorage::Remove ] [@ mozilla::DataStorage::GetTableForType ]

Bug 1535697 has been backed out, new Nightlies have been requested.

Fixed by backout (see bug 1535697).

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.