Closed Bug 154760 Opened 18 years ago Closed 18 years ago

download manager and mozilla crash when i try to download a file with צה� etc. in the name. [@nsAssignmentSet::GetAssignmentFor]

Categories

(SeaMonkey :: Download & File Handling, defect, critical)

x86
Windows 2000
defect
Not set
critical

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 132905

People

(Reporter: fpeter, Assigned: bugzilla)

Details

(Keywords: crash)

Crash Data

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a) Gecko/20020611
BuildID:    2002061104

download manager and mozilla crash when i try to download a file with צה� etc.
in the name. download is ok, but mozilla is gone with:
0x606abaf at 0x00000010 the memory could not be read
unhandled exeption in mozilla.exe (GKCONTENT.DLL): 0xC000005 Access Violation

Reproducible: Always
Steps to Reproduce:
1.open a web page
2.select a file
3.in the save as dialog box type to the filename field צהצה etc.
4.click save/ok

Actual Results:  0x606abaf at 0x00000010 the memory could not be read
unhandled exeption in mozilla.exe (GKCONTENT.DLL): 0xC000005 Access Violation

Expected Results:  download

download is correct, the file is not corrupt and has the given (צהצ�) name
I can reproduce it in 2002062608 (W2000). Talklback ID is TB7797654W
nsAssignmentSet::GetAssignmentFor
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsRuleNetwork.cpp, line 596]
nsTemplateMatch::GetAssignmentFor
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsTemplateMatch.cpp, line 52]
nsXULTemplateBuilder::SubstituteTextReplaceVariable
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTemplateBuilder.cpp,
line 1168]
nsXULTemplateBuilder::ParseAttribute
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTemplateBuilder.cpp,
line 1077]
nsXULTemplateBuilder::SubstituteText
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTemplateBuilder.cpp,
line 1125]
nsXULContentBuilder::BuildContentFromTemplate
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULContentBuilder.cpp,
line 783]
nsXULContentBuilder::CreateTemplateContents
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULContentBuilder.cpp,
line 1385]
nsXULContentBuilder::CreateTemplateAndContainerContents
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULContentBuilder.cpp,
line 1209]
nsXULContentBuilder::CreateContents
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULContentBuilder.cpp,
line 1765]
nsXULElement::EnsureContentsGenerated
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3654]
nsXULElement::ChildCount
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 2175]
nsXULElement::GetChildNodes
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 768]
nsXULElement::GetElementsByTagName
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3684]
nsXULElement::GetElementsByTagName
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3718]
nsXULElement::GetElementsByTagName
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3718]
nsXULElement::GetElementsByTagName
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3718]
nsXULElement::GetElementsByTagName
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 1425]
XPTC_InvokeByIndex
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp,
line 106]
XPCWrappedNative::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp, line 1996]
XPC_WN_CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1267]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 790]
js_Interpret [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 2744]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 806]
js_InternalInvoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 881]
JS_CallFunctionValue [c:/builds/seamonkey/mozilla/js/src/jsapi.c, line 3430]
nsJSContext::CallEventHandler
[c:/builds/seamonkey/mozilla/dom/src/base/nsJSEnvironment.cpp, line 1045]
nsJSEventListener::HandleEvent
[c:/builds/seamonkey/mozilla/dom/src/events/nsJSEventListener.cpp, line 184]
nsXBLPrototypeHandler::ExecuteHandler
[c:/builds/seamonkey/mozilla/content/xbl/src/nsXBLPrototypeHandler.cpp, line 457]
nsXBLPrototypeHandler::BindingAttached
[c:/builds/seamonkey/mozilla/content/xbl/src/nsXBLPrototypeHandler.cpp, line 505]
nsXBLPrototypeBinding::BindingAttached
[c:/builds/seamonkey/mozilla/content/xbl/src/nsXBLPrototypeBinding.cpp, line 441]
nsXBLBinding::ExecuteAttachedHandler
[c:/builds/seamonkey/mozilla/content/xbl/src/nsXBLBinding.cpp, line 1040]
nsBindingManager::ProcessAttachedQueue
[c:/builds/seamonkey/mozilla/content/xbl/src/nsBindingManager.cpp, line 913]
nsCSSFrameConstructor::ContentInserted
[c:/builds/seamonkey/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp,
line 9158]
nsCSSFrameConstructor::ContentAppended
[c:/builds/seamonkey/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp,
line 8318]
StyleSetImpl::ContentAppended
[c:/builds/seamonkey/mozilla/content/base/src/nsStyleSet.cpp, line 1527]
PresShell::ContentAppended
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 5317]
nsXULDocument::ContentAppended
[c:/builds/seamonkey/mozilla/content/xul/document/src/nsXULDocument.cpp, line 2258]
nsXULContentBuilder::Rebuild
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULContentBuilder.cpp,
line 1744]
nsXULContentBuilder::Rebuild
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULContentBuilder.cpp,
line 1753]
XPTC_InvokeByIndex
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp,
line 106]
XPCWrappedNative::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp, line 1996]
XPC_WN_CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1267]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 790]
js_Interpret [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 2744]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 806]
js_InternalInvoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 881]
JS_CallFunctionValue [c:/builds/seamonkey/mozilla/js/src/jsapi.c, line 3430]
nsJSContext::CallEventHandler
[c:/builds/seamonkey/mozilla/dom/src/base/nsJSEnvironment.cpp, line 1045]
nsJSEventListener::HandleEvent
[c:/builds/seamonkey/mozilla/dom/src/events/nsJSEventListener.cpp, line 184]
nsEventListenerManager::HandleEventSubType
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp, line
1222]
nsEventListenerManager::HandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp, line
1904]
GlobalWindowImpl::HandleDOMEvent
[c:/builds/seamonkey/mozilla/dom/src/base/nsGlobalWindow.cpp, line 740]
DocumentViewerImpl::LoadComplete
[c:/builds/seamonkey/mozilla/content/base/src/nsDocumentViewer.cpp, line 1544]
nsDocShell::EndPageLoad
[c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp, line 3954]
nsWebShell::EndPageLoad
[c:/builds/seamonkey/mozilla/docshell/base/nsWebShell.cpp, line 731]
nsDocShell::OnStateChange
[c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp, line 3868]
nsDocLoaderImpl::FireOnStateChange
[c:/builds/seamonkey/mozilla/uriloader/base/nsDocLoader.cpp, line 1175]
nsDocLoaderImpl::doStopDocumentLoad
[c:/builds/seamonkey/mozilla/uriloader/base/nsDocLoader.cpp, line 834]
nsDocLoaderImpl::DocLoaderIsEmpty
[c:/builds/seamonkey/mozilla/uriloader/base/nsDocLoader.cpp, line 732]
nsDocLoaderImpl::OnStopRequest
[c:/builds/seamonkey/mozilla/uriloader/base/nsDocLoader.cpp, line 663]
nsLoadGroup::RemoveRequest
[c:/builds/seamonkey/mozilla/netwerk/base/src/nsLoadGroup.cpp, line 537]
nsCachedChromeChannel::HandleStopLoadEvent
[c:/builds/seamonkey/mozilla/rdf/chrome/src/nsChromeProtocolHandler.cpp, line 481]
PL_HandleEvent [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c, line 597]
PL_ProcessPendingEvents [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c,
line 530] 

*** This bug has been marked as a duplicate of 132905 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Keywords: crash
Resolution: --- → DUPLICATE
Summary: download manager and mozilla crash when i try to download a file with צה� etc. in the name. → download manager and mozilla crash when i try to download a file with צה� etc. in the name. [@nsAssignmentSet::GetAssignmentFor]
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
Crash Signature: [@nsAssignmentSet::GetAssignmentFor]
You need to log in before you can comment on or make changes to this bug.