Closed Bug 1547651 Opened 3 years ago Closed 3 years ago

shutdown_browser() should not wait 15s before killing the browser

Categories

(Testing :: Raptor, enhancement, P1)

Version 3
enhancement

Tracking

(firefox70 fixed)

RESOLVED FIXED
mozilla70
Tracking Status
firefox70 --- fixed

People

(Reporter: whimboo, Assigned: whimboo)

References

Details

Attachments

(1 file)

Receiving the __raptor_shutdownBrowser message in the control server instructs it to kill the browser. Sadly the method shutdown_browser() creates a new thread with the wait_for_quit() as run method, which implicitly waits 15s before killing the browser.

Given that the above message should immediately kill the browser there is an extra delay of 15s for each and every browser shutdown.

Cannot we simply use 0 as timeout in this case so that the browser process is killed instantly?

Priority: -- → P3

Rob, are you ok with that change? If yes, I can come up with the patch. But I will be sure that is wanted and ok to do.

Flags: needinfo?(rwood)

(In reply to Henrik Skupin (:whimboo) [⌚️UTC+1] from comment #1)

Rob, are you ok with that change? If yes, I can come up with the patch. But I will be sure that is wanted and ok to do.

Yes please, I don't recall any specific reason for that 15s wait before shutdown. Thanks!

Flags: needinfo?(rwood)
Assignee: nobody → hskupin
Status: NEW → ASSIGNED
Type: defect → enhancement
Priority: P3 → P1

The patch as is cannot land due to a race condition with symbolicating the gecko profile. For details see the revision in Phabricator.

As such I won't continue on that patch.

Assignee: hskupin → nobody
Status: ASSIGNED → NEW
Priority: P1 → P3
Attachment #9063173 - Attachment is obsolete: true
Depends on: 1550702

This works as expected now:

06:04:47     INFO -  PID 1830 | console.log: "[raptor-runnerjs] saving gecko profile"
06:04:47     INFO -  raptor-control-server Info: received webext_status: saving gecko profile
[..]
06:04:51     INFO -  PID 1830 | console.log: "[raptor-runnerjs] posting to control server"
06:04:51     INFO -  PID 1830 | console.log: "[raptor-runnerjs] raptor-youtube-playback-firefox-live_pagecycle_1.profile"
06:04:51     INFO -  PID 1830 | console.log: "[raptor-runnerjs] stopping gecko profiling"
06:04:51     INFO -  raptor-control-server Info: received gecko profile filename: raptor-youtube-playback-firefox-live_pagecycle_1.profile
06:04:51     INFO -  raptor-control-server Info: moved gecko profile to /var/folders/c2/q_47wqh13n902fj9_zxczclr0000gn/T/tmpLDeWx5/raptor-youtube-playback-firefox-live_pagecycle_1.profile
06:04:51     INFO -  raptor-control-server Info: received webext_status: stopping gecko profiling
[..]
06:04:51     INFO -  raptor-control-server Info: received request to shutdown the browser
06:04:51     INFO -  raptor-control-server Info: shutting down browser (pid: 1830)
Assignee: nobody → hskupin
Status: NEW → ASSIGNED
Priority: P3 → P1
Attachment #9063173 - Attachment is obsolete: false
Pushed by rwood@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1a4dad7c7416
[raptor] shutdown_browser() should not wait 15s before killing the browser. r=perftest-reviewers,stephendonner,rwood
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Regressions: 1564835
You need to log in before you can comment on or make changes to this bug.