Proxy prefs migration screw up mozilla behavior

VERIFIED FIXED in M11

Status

()

defect
P3
normal
VERIFIED FIXED
20 years ago
20 years ago

People

(Reporter: mcafee, Assigned: gagan)

Tracking

Trunk
Other
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

20 years ago
linux, apprunner
Running apprunner -installer migrates all the proxy prefs,
first run of apprunner wouldn't load any pages.
I had to delete all the proxy prefs to fix this.
Default proxy pref is none, I think.
(Reporter)

Updated

20 years ago
Assignee: dbragg → sspitzer
Status: NEW → ASSIGNED
Target Milestone: M11
accpeting.  marking m11.
mcafee, can you paste your 4.x proxy prefs in the bug report, so I can test it?

adding gagan because this is proxy related.
(Reporter)

Comment 3

20 years ago
Posted file my 4.x proxy prefs
(Assignee)

Updated

20 years ago
Assignee: sspitzer → gagan
Status: ASSIGNED → NEW
Component: Profile Migration → Necko
(Assignee)

Comment 4

20 years ago
This is my bug. And I know about it. All mine. If you really wanna know- I have
to add the proxy.type pref reading capability. Currently there is only a check
for HTTP proxy and so it automatically tries to use it even if the proxy.type
prefs says don't.

Comment 5

20 years ago
Yup. Gagan's got it. We're not honoring the proxy.type pref.
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED

Comment 6

20 years ago
*** Bug 16674 has been marked as a duplicate of this bug. ***

Updated

20 years ago
Target Milestone: M11 → M12

Comment 7

20 years ago
if there is an easy fix for this m11.  otherwise m12
(Assignee)

Updated

20 years ago
Target Milestone: M12 → M11
(Assignee)

Comment 8

20 years ago
fixed. need review. back to m11.
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED

Comment 9

20 years ago
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 10

20 years ago
build 1999121308
You need to log in before you can comment on or make changes to this bug.