Closed Bug 1547826 Opened 4 years ago Closed 3 years ago

Enter key does not work in address bar 60.6.1esr

Categories

(Firefox :: Address Bar, defect, P3)

60 Branch
Desktop
macOS
defect

Tracking

()

RESOLVED INCOMPLETE

People

(Reporter: natefortner, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.108 Safari/537.36

Steps to reproduce:

I don't know. Sometimes when I open a new tab this occurs, but not always.

Actual results:

I click enter and nothing happens. It doesn't load the new page, it just does nothing.

Expected results:

Should load the page or search I am typing

OS: Unspecified → macOS
Hardware: Unspecified → Desktop
Summary: Enter key does not work in address bar → Enter key does not work in address bar 60.6.1esr
Component: Untriaged → Address Bar

Please check you don't have a userchrome.css or a chrome/ folder in yout profile folder, those hacks may cause this kind of problems. Safe mode is also a good way to check for other profile issues https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Flags: needinfo?(natefortner)

Checked for files listed, none found. Also tried in safe mode, same issue occurred.

Flags: needinfo?(natefortner)

Bug 1427166 is similar, and bug 1438329 should have fixed it, and it landed in 60. So it's worrying that this bug is filed against 60.6.1 esr. It's going to be hard to debug if it doesn't happen reliably (which I don't doubt).

Priority: -- → P3
See Also: → 1427166, 1438329

I'm having the same problem too with Firefox 60.9.0esr on Debian 10.1 + XFCE.
I spend some time figuring out how this works and I discovered the following:

1 - On a new window (new or existing instance), pressing the return key on the address bar works as expected.
2 - This continues until the user deletes then adds characters, so the suggestion menu should appear then disappear respectively. Finally,
3 - the return key won't do anything anymore, as per the bug description.
From here, the address bar remains broken until a new window is opened, go to statement 1.

Note however, if the suggestion menu remain present after typing into the address bar, then the return key should work as expected, but the address bar remains broken/working depending on whether it's state matches statement 1 or 3.

Additionally, I haven't encountered such issue with Windows (running non-ESR versions).

I then noticed that the focus of the enter key may have remained in the web page instead of the address bar.

That's all I'm adding to this report.

the XFCE manager is known to have problems with Firefox, we have various bugs on file with it. We officially support gtk.
I don't think your XFCE problem is the same as the originally reported one here, you should file a separate bug, and it's likely a bug between the widget and the window manager.

I wonder if the original reporter on MacOS may check the focus though, is the focus being moved away from the input field? Could you have some accessibility option enabled on MacOS, related to that?

Flags: needinfo?(natefortner)
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Flags: needinfo?(natefortner)
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.