Closed Bug 1547855 Opened 5 months ago Closed 5 months ago

Intermittent [TV] toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_downloadAutoFailures_bgWin.js | Test timed out -

Categories

(Toolkit :: Application Update, defect, P3)

Unspecified
macOS
defect

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- unaffected
firefox68 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: rstrong)

References

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file, 2 obsolete files)

#[markdown(off)]
Filed by: nbeleuzu [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=243421608&repo=autoland

https://queue.taskcluster.net/v1/task/StpFADdER_K6w-eP_99drg/runs/0/artifacts/public/logs/live_backing.log

https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/StpFADdER_K6w-eP_99drg/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1

21:22:17 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_downloadAutoFailures_bgWin.js | update-available notification is showing -
21:22:17 INFO - Buffered messages logged at 21:15:31
21:22:17 INFO - Longer timeout required, waiting longer... Remaining timeouts: 9
21:22:17 INFO - Buffered messages logged at 21:16:16
21:22:17 INFO - Longer timeout required, waiting longer... Remaining timeouts: 8
21:22:17 INFO - Buffered messages logged at 21:17:01
21:22:17 INFO - Longer timeout required, waiting longer... Remaining timeouts: 7
21:22:17 INFO - Buffered messages logged at 21:17:47
21:22:17 INFO - Longer timeout required, waiting longer... Remaining timeouts: 6
21:22:17 INFO - Buffered messages logged at 21:18:32
21:22:17 INFO - Longer timeout required, waiting longer... Remaining timeouts: 5
21:22:17 INFO - Buffered messages logged at 21:19:11
21:22:17 INFO - Console message: [JavaScript Error: "Polling for changes failed: Unexpected content-type "text/html;charset=utf-8"." {file: "resource://services-settings/remote-settings.js" line: 208}]
21:22:17 INFO - remoteSettingsFunction/remoteSettings.pollChanges@resource://services-settings/remote-settings.js:208:13
21:22:17 INFO - async*notify@resource://services-settings/RemoteSettingsComponents.jsm:22:20
21:22:17 INFO - TM_notify/<@resource://gre/modules/UpdateTimerManager.jsm:192:48
21:22:17 INFO - TM_notify@resource://gre/modules/UpdateTimerManager.jsm:239:7
21:22:17 INFO -
21:22:17 INFO - Buffered messages logged at 21:19:17
21:22:17 INFO - Longer timeout required, waiting longer... Remaining timeouts: 4
21:22:17 INFO - Buffered messages logged at 21:20:02
21:22:17 INFO - Longer timeout required, waiting longer... Remaining timeouts: 3
21:22:17 INFO - Buffered messages logged at 21:20:47
21:22:17 INFO - Longer timeout required, waiting longer... Remaining timeouts: 2
21:22:17 INFO - Buffered messages logged at 21:21:32
21:22:17 INFO - Longer timeout required, waiting longer... Remaining timeouts: 1
21:22:17 INFO - Buffered messages finished
21:22:17 INFO - TEST-UNEXPECTED-FAIL | toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_downloadAutoFailures_bgWin.js | Test timed out -
21:22:17 INFO - GECKO(2179) | MEMORY STAT | vsize 5477MB | residentFast 326MB | heapAllocated 73MB
21:22:17 INFO - TEST-OK | toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_downloadAutoFailures_bgWin.js | took 450084ms

21:22:17 INFO - 21:14:47:512 | TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/update/tests/browser/shared.js | [setUpdateURL : 220] setting app.update.url to http://127.0.0.1:8888/browser/toolkit/mozapps/update/tests/browser/app_update.sjs?badURL=1&appVersion=68.0a1
21:22:17 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_downloadAutoFailures_bgWin.js | The doorhanger is not showing for the background window -
21:22:17 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_downloadAutoFailures_bgWin.js | The badge is showing for the background window -
21:22:17 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_downloadAutoFailures_bgWin.js | What's new link points to the test_details URL -
21:22:17 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_downloadAutoFailures_bgWin.js | What's new link is not hidden. -
21:22:17 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_downloadAutoFailures_bgWin.js | update-available notification is showing -
21:22:17 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_downloadAutoFailures_bgWin.js | The doorhanger is not showing for the background window -
21:22:17 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_downloadAutoFailures_bgWin.js | The badge is showing for the background window -
21:22:17 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_downloadAutoFailures_bgWin.js | What's new link points to the test_details URL -
21:22:17 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_downloadAutoFailures_bgWin.js | What's new link is not hidden. -
21:22:17 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_downloadAutoFailures_bgWin.js | update-available notification is showing -

This appears to be similar to bug 1526865 comment #3 which affected macOS though in this case it is due to the waitForCondition call in browser_doorhanger_bc_downloadAutoFailures_bgWin.js waiting the default time. I also had to increase these in head.js to fix these types of TV failures on macOS.

Assignee: nobody → robert.strong.bugs
Status: NEW → ASSIGNED
Priority: P5 → P3

When running these tests with --verify (e.g. TV) the tests intermittently fail due to it taking longer for the UI condition to be met.

Attachment #9061820 - Attachment is obsolete: true

There is a race between adding the event listener and showing the UI so just wait until the UI is shown

Pushed by rstrong@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/62b63caf1a90
use waitForCondition instead of waitForEvent. r=bytesized
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68

The failures when running the app update tests during TV runs print an activity stream error to the console and this will at the least eliminate it as a cause for the failure and possibly will prevent these tests from failing during TV runs.

Attachment #9062109 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.