regression, clicking on image in imgur.com & back crashes tab

VERIFIED DUPLICATE of bug 1547911

Status

()

defect
VERIFIED DUPLICATE of bug 1547911
4 months ago
4 months ago

People

(Reporter: Mark12547, Unassigned)

Tracking

68 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

  • Create a new profile for Nightly

  • Launch Nightly using that new profile

  • Browse to https://imgur.com/

  • Click on an image (just about any image, apparently, same results with a static image and videos)

  • Click on the BACK button

Actual results:

The tab crashes, signature of crash is @ mozilla::dom::BrowsingContext::RestoreChildren

Sample crash: https://crash-stats.mozilla.org/report/index/ba1ccb7b-1663-4a26-adaa-4080e0190430

Expected results:

I would expect to see the https://imgur.com/ home page.

(More info will be posted later.)

mozregression-gui ended with:

Bug 1471869 - Re-attach cached contexts in bulk. r=nika

This makes restoring from bfcache send less messages. It also
separates detach/attach from the caching logic, making it more clear
that caching is going on.

Differential Revision: https://phabricator.services.mozilla.com/D28670

If you need more info, please let me know.
Thank you!

Status: UNCONFIRMED → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1547911
Component: Untriaged → DOM: Core & HTML
Product: Firefox → Core
Version: Trunk → 68 Branch

This bug is back.

To reproduce:

  1. Create a brand new profile in Nightly.

  2. Launch Nightly using that new profile.

  3. Add extension: either uBlock Origin or AdBlock Plus

  4. Shut down that Nightly.

  5. Launch Nightly using that same (new) profile.

  6. Navigate to https://imgur.com/

  7. Click on an image to go into a story. (Can be video or still picture)

  8. Click on the Back button by the URL bar.

  9. Note: TAB CRASHED

This does not happen if in step 3 I had added IPvFoo instead of an ad blocker.

PS: This is after the fix for "invalid intermediate certificate".

Firefox Nightly 68.0a1 (2019-05-06) (64-bit) Build-id: 20190506130308 under Windows 10 (64-bit).

OOps! Later discovered https://bugzilla.mozilla.org/show_bug.cgi?id=1549373 and that appears to be the active Bug for the current incarnation of this bug. (Content of comments 5 & 6 already posted over there.)

You need to log in before you can comment on or make changes to this bug.