Closed Bug 1547924 Opened 8 months ago Closed 8 months ago

The new Onboarding UX strings are not updated according to Bug 1546617

Categories

(Firefox for Android :: Awesomescreen, defect, P1)

ARM
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 67
Tracking Status
firefox67 --- verified
firefox68 --- verified
firefox69 --- affected

People

(Reporter: eliza.balazs, Assigned: petru)

References

Details

Attachments

(1 file)

Environment:
Device:
Samsung Galaxy Note 8 (Android 9);
Nexus 6P (Android 8.1.0)
Google Pixel C (Android 8.0.0; Tablet);
Nokia 6 (Android 7.1.1);

Build: Beta 67.0b15;

Steps to reproduce:

  1. Install Fennec Beta;
  2. Launch Fennec Beta;
  3. Observe the Welcome screen panels.

Expected result:
The new Onboarding UX strings are updated.

Actual result:
The new Onboarding UX strings are not updated.

Notes:

Summary: Welcome screen has two "Welcome" panels → The new Onboarding UX strings are not updated according to Bug 1546617
See Also: → 1546617, 1545805

So on Nightly it works ok, the problems are only on beta, and only on some devices, right?

What locale is it set on those devices on which you see the issue?
Does the problem still reproduces if you do a fresh install from Playstore / Mozilla repo or only when "Clear data" is used?

Can you also please try the troublesome scenario without an active Internet connection and report if the issue still reproduces?

Flags: needinfo?(eliza.balazs)

Hi, Petru!

Without an active Internet connection this is not reproducible.

Thank you.

Flags: needinfo?(eliza.balazs)

Then the issue then should be easy to fix.
I think it is happening on Beta and not on Nightly because of the feature that allows overriding Onboarding from Leanplum (bug 1386192). Leanplum is enabled by default on Beta+ but not on Nightly.
If overriden values for onboarding are not found / downloaded from Leanplum then the app will fallback on the "default" local values. But this values which Leanplum falls back to have not been updated in bug 1546617.

Will work on a quick fix, thanks Eliza!

  • Added the LAST_PRIVACY case for when the user is already signed into Firefox;
  • Use the new default onboarding strings and images. If they are localized.

Comment on attachment 9061630 [details]
Bug 1547924 - Ensure Leanplum Onboarding falls back to the new Onboarding UX; r?VladBaicu

Beta/Release Uplift Approval Request

  • User impact if declined: Beta+ users for which Leanplum is enabled would see a mixup of the old and the new Onboarding UX.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: - fresh install or update to this build followed by a "Clear data" in system settings
  • open app with or without being logged in with a Firefox account
  • confirm the correct number of onboarding screens with updated strings and imagery
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Small targeted change.
  • String changes made/needed:
Attachment #9061630 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Assignee: nobody → petru.lingurar
Status: NEW → ASSIGNED

Comment on attachment 9061630 [details]
Bug 1547924 - Ensure Leanplum Onboarding falls back to the new Onboarding UX; r?VladBaicu

Uplift approved for 67 beta 15 (we will do a fennec-only build2 with this patch later today)

Attachment #9061630 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67

Verified as fixed on Beta 67.0b15 build 2.
Devices:

  • Samsung Galaxy Note 8 (Android 9);
  • Nexus 6P (Android 8.1.0);
  • Google Pixel C (Android 8.0.0);
  • Nokia 6 (Android 7.1.1);
  • Nexus 6 (Android 6.0.1).
Status: RESOLVED → VERIFIED
Flags: qe-verify+
See Also: → 1553079
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/49f7d8f42f5e
Ensure Leanplum Onboarding falls back to the new Onboarding UX; r=VladBaicu

Can you request uplift to beta, please?

Flags: needinfo?(petru.lingurar)

(In reply to Sebastian Hengst [:aryx] (needinfo on intermittent or backout) from comment #10)

Can you request uplift to beta, please?

Setting status flag 68=affected to track this uplift.

Duplicate of this bug: 1553079

(In reply to Sebastian Hengst [:aryx] (needinfo on intermittent or backout) from comment #10)

Can you request uplift to beta, please?

Seems like I can't make a second uplift request since a beta request has already been approved.

Flags: needinfo?(petru.lingurar)
See Also: → 1555257

Verified as fixed on Beta 68.0b10, Nightly 68.0a1 (2019-06-13) with Nexus 6P (Android 8.1.0) and OnePlus 5T(Android 9).
Due to my findings, I'll mark this issue as verified on Firefox 68. Thanks.

You need to log in before you can comment on or make changes to this bug.