Closed Bug 1547954 Opened 6 months ago Closed 6 months ago

Intermittent toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_patch_partialBadSize_completeBadSize.js | A promise chain failed to handle a rejection: BitsError {type: 39, action: 6, stage: 2, codeType: none} - stack: BitsError@resource://gre/

Categories

(Toolkit :: Application Update, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1546957

People

(Reporter: intermittent-bug-filer, Unassigned)

Details

(Keywords: intermittent-failure, regression)

Filed by: rgurzau [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=243584156&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/T_qaJiZjTuexoVeHMEs88Q/runs/0/artifacts/public/logs/live_backing.log


11:26:05 INFO - TEST-START | toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_patch_partialBadSize_completeBadSize.js
11:26:05 INFO - GECKO(5584) | JavaScript error: resource://gre/modules/Bits.jsm, line 79: Error: BitsError {type: 39, action: 6, stage: 2, codeType: none}
11:26:05 INFO - TEST-INFO | started process screenshot
11:26:05 INFO - TEST-INFO | screenshot: exit 0
11:26:05 INFO - Buffered messages logged at 11:26:05
11:26:05 INFO - Entering test bound setupTestCommon
11:26:05 INFO - Leaving test bound setupTestCommon
11:26:05 INFO - Entering test bound doorhanger_bc_patch_partialBadSize_completeBadSize
11:26:05 INFO - Console message: [JavaScript Error: "Error: BitsError {type: 39, action: 6, stage: 2, codeType: none}" {file: "resource://gre/modules/Bits.jsm" line: 79}]
11:26:05 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_patch_partialBadSize_completeBadSize.js | The right notification showed up. -
11:26:05 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_patch_partialBadSize_completeBadSize.js | There should not be an active update -
11:26:05 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_patch_partialBadSize_completeBadSize.js | What's new link is not hidden. -
11:26:05 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_patch_partialBadSize_completeBadSize.js | What's new link href should equal http://127.0.0.1:8888/browser/toolkit/mozapps/update/tests/browser/app_update.sjs?uiURL=DETAILS -
11:26:05 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_patch_partialBadSize_completeBadSize.js | update-available notification is showing -
11:26:05 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_patch_partialBadSize_completeBadSize.js | The right notification showed up. -
11:26:05 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_patch_partialBadSize_completeBadSize.js | There should not be an active update -
11:26:05 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_patch_partialBadSize_completeBadSize.js | What's new link is not hidden. -
11:26:05 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_patch_partialBadSize_completeBadSize.js | What's new link href should equal http://127.0.0.1:8888/browser/toolkit/mozapps/update/tests/browser/app_update.sjs?uiURL=DETAILS -
11:26:05 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_patch_partialBadSize_completeBadSize.js | update-available notification is showing -
11:26:05 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_patch_partialBadSize_completeBadSize.js | The right notification showed up. -
11:26:05 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_patch_partialBadSize_completeBadSize.js | There should not be an active update -
11:26:05 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_patch_partialBadSize_completeBadSize.js | What's new link is not hidden. -
11:26:05 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_patch_partialBadSize_completeBadSize.js | What's new link href should equal http://127.0.0.1:8888/browser/toolkit/mozapps/update/tests/browser/app_update.sjs?uiURL=DETAILS -
11:26:05 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_patch_partialBadSize_completeBadSize.js | update-manual notification is showing -
11:26:05 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_patch_partialBadSize_completeBadSize.js | The page's url should equal http://127.0.0.1:8888/browser/toolkit/mozapps/update/tests/browser/downloadPage.html -
11:26:05 INFO - Buffered messages finished
11:26:05 INFO - TEST-UNEXPECTED-FAIL | toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_patch_partialBadSize_completeBadSize.js | A promise chain failed to handle a rejection: BitsError {type: 39, action: 6, stage: 2, codeType: none} - stack: BitsError@resource://gre/modules/Bits.jsm:79:5
11:26:05 INFO - failure@resource://gre/modules/Bits.jsm:151:21
11:26:05 INFO - cancelAsync/<@resource://gre/modules/Bits.jsm:288:21
11:26:05 INFO - requestPromise/<@resource://gre/modules/Bits.jsm:176:7
11:26:05 INFO - requestPromise@resource://gre/modules/Bits.jsm:140:10
11:26:05 INFO - cancelAsync@resource://gre/modules/Bits.jsm:287:12
11:26:05 INFO - Downloader_cancel@resource://gre/modules/UpdateService.jsm:3728:27
11:26:05 INFO - Downloader_onProgress@resource://gre/modules/UpdateService.jsm:4249:12
11:26:05 INFO - wrappedObserver_onProgress@resource://gre/modules/Bits.jsm:426:20

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1546957
You need to log in before you can comment on or make changes to this bug.