installing gestures as root left menus unavailable

RESOLVED EXPIRED

Status

RESOLVED EXPIRED
17 years ago
3 years ago

People

(Reporter: jim, Assigned: dveditz)

Tracking

Trunk
x86
FreeBSD

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mozdev:mozgest])

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
I don't have a menubar (though there is a small square with a down-arrow in it
(sorry, don't know what that control is called) where the menubar would normally
be, which functions just like the controls on the other two bars). I don't even
get a window when I right-click. ^T/^N doesn't work either

I'm guessing this is a config issue because everything works fine if I run
mozilla as root. This happened right after I tried to install Mouse Gesture
Support which failed when trying to install as my normal user (couldn't install
chrome).
Reporter:
Can you attach a screenshot ?

Possible it works again if you remove/rename the file "localstore.rdf" in your
profile.

Comment 2

17 years ago
reporter- Did you install gestures as root?  make sure you have permissions set
correctly on the files it installed.  I saw similar symptoms with googlebar a
few times.  I don't know if that would be a mozilla bug or a gestures bug.
(Reporter)

Comment 3

17 years ago
Created attachment 89692 [details]
Screenshot

I tried rm -rf'ing /root/.mozilla and moving /usr/X11R6/.../localstore.rdf and
US/localstore.rdf, still no luck.

I did install gestures as root, and sure enough that's what broke things. I now
have my menus back.

Is this a bug with gestures or a bug with the installer? Overall, the install
process is rather cumbersom for mozilla not being run as root; it's nice to be
able to install only for my user, but I'd also like an easy way to install for
everyone using root privledges (prefferably via something like sudo).

Comment 4

16 years ago
xpinstall?
Assignee: Matti → dveditz
Component: Browser-General → Installer: XPInstall Engine
QA Contact: imajes-qa → jimmylee
Summary: Menus no longer available → installing gestures as root left menus unavailable
Whiteboard: [mozdev:mozgest]
Yes, rights problem. 
Files of mozgest are -r-------- root root 
 
Solution: 
# cd /opt/mozilla/mozilla/chrome 
# chmod -R go+r mozgest 
 
(change /opt/mozilla with you mozilla installation directory) 
Hem. Sorry, read "/opt/mozilla/chrome" and not "/opt/mozilla/mozilla/chrome". 
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → EXPIRED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.