Closed Bug 1548042 Opened 4 months ago Closed 4 months ago

Special FxA Snippet on New Tab for Firefox 67

Categories

(Firefox :: Messaging System, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 67
Iteration:
68.4 - Apr 29 - May 12
Tracking Status
firefox67 + verified

People

(Reporter: rrosario, Assigned: rrosario)

References

Details

(Keywords: github-merged)

Attachments

(1 file)

This is a new special snippet template that renders below the search bar on newtab page. See Bug 1539700 for more details.

We would like to get this uplifted to beta as one commit for convenience and because we don't want individual pieces to be backed out (it's all or nothing).

Ricky, do you have an ETA on the uplift? Also, it is my understandig that you want it for Trailhead, not for 67.0, can you confirm please? Thanks

Flags: needinfo?(rrosario)

(In reply to Pascal Chevrel:pascalc from comment #1)

Ricky, do you have an ETA on the uplift? Also, it is my understandig that you want it for Trailhead, not for 67.0, can you confirm please? Thanks

We just need to export the patch from the github repo, so we can have that done today. And we want this part to be uplifted to 67.0 (not Trailhead).

Flags: needinfo?(rrosario)
Assignee: nobody → rrosario

If it's not targeting our Trailhead release, maybe it shouldn't block bug 1545802.

Priority: -- → P1

Comment on attachment 9063180 [details]
Bug 1548042 - Special FxA Snippet on New Tab for Firefox 67

Beta/Release Uplift Approval Request

  • User impact if declined: Users won't see the new FXA snippet under the search box on about:newtab.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: The snippets team (:giorgos, :jcollings) will need to deploy a snippet that targets beta 67. Then the snippet will appear in the new spot on newtab page. See Bug 1539700 for more details.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The patch is pretty big, mostly because it contains changes to the prerendered file for every single locale. But the actual changes aren't that complex and have been tested and verified on Nightly. Also, the snippet can be turned off from the snippets server if any issue were to come up.
  • String changes made/needed: N/A
Attachment #9063180 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Iteration: --- → 68.4 - Apr 29 - May 12
Blocks: 1550098

Joe and Reese - do you approve this uplift into 67.0 in support of Trailhead?

Flags: needinfo?(marissawood)
Flags: needinfo?(joe-bugzilla)

2019-05-08 - This is approved. R+

Flags: needinfo?(marissawood)

Comment on attachment 9063180 [details]
Bug 1548042 - Special FxA Snippet on New Tab for Firefox 67

Evaluated as low risk, uplift approved for beta 19, thanks.

Attachment #9063180 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Status: NEW → RESOLVED
Closed: 4 months ago
Flags: needinfo?(joe-bugzilla)
Resolution: --- → FIXED
No longer depends on: 1550714
QA Whiteboard: [qa-triaged]

Removing the qe-verify flag as we signed off (GREEN) on this feature via email on 5/15/2019. Link to test run.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Component: Activity Streams: Newtab → Messaging System
You need to log in before you can comment on or make changes to this bug.