Closed Bug 1548076 Opened 10 months ago Closed 8 months ago

Zoom hotkeys are inconsistent when developer tools are open

Categories

(DevTools :: Inspector, defect, P3)

66 Branch
defect

Tracking

(firefox69 fixed)

RESOLVED FIXED
Firefox 69
Tracking Status
firefox69 --- fixed

People

(Reporter: dmurvihill, Assigned: herpiko)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:66.0) Gecko/20100101 Firefox/66.0

Steps to reproduce:

On any page, open developer tools
Cmd + '+' to zoom in
Cmd + '-' to zoom out.

Actual results:

Web page zoomed in
Developer tools zoomed out

Expected results:

One pane or the other should zoom in and out, depending on which one has focus

Hi,

I wasn't able to reproduce this issue using Firefox 66.0.4(2019-05-04) or Firefox Nightly 68.0a1(2019-05-06)

Please test if the issue occurs in Safe mode. Here is a link that can help you with that:
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

If the issue still occurs, please test it using a new profile, you can find the steps to do that below:
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles?redirectlocale=en-US&redirectslug=Managing-profiles#w_starting-the-profile-manager

Thank you for reporting!

Flags: needinfo?(dmurvihill)

Reproduced in both safe mode and with a new profile.

It appears FireFox behaves normally when the focus is on the content window. The incorrect behavior occurs when the focus is on the developer tools window. The zoom in button still zooms in the page but it should zoom in the developer tools instead.

Flags: needinfo?(dmurvihill)

I cannot reproduce this issue on Firefox 66.0.5 or Firefox Nightly 68.0a1, it does only zoom the focused window on my end.
I will add a component in order to involve the development team in reviewing this issue.

Component: Untriaged → Inspector
Product: Firefox → DevTools

I can't reproduce either.
Here are my steps:

  • open a page

  • open DevTools

  • click inside the content page (to make sure focus is there)

  • press Cmd + to zoom in ==> the page zooms in, which is expected. DevTools does not, which is expected too.

  • click inside DevTools (to make sure focus is there)

  • press Cmd + to zoom in ==> the DevTools toolbox zooms in, which is expected. The content page does not, which is expected too.

Now, I did notice one buggy case:

  • click in the page to move the focus there
  • now click somewhere in the toolbar of DevTools (where the tools are listed)
  • press Cmd + ==> the page zooms in, which is not expected.

Are you getting something different dmurvihill?

Flags: needinfo?(dmurvihill)
Priority: -- → P3

Are you getting something different dmurvihill?

I can reproduce this. If we clcik on the blank spot of tool tabs, it won't focus on devtool.

Can I work on this?

Attachment #9073428 - Attachment description: Bug 1548076. Try to focus on devtool even if the click hit blank spot on tool tabs. r=longsonr → Bug 1548076. Try to focus on devtool even if the click hit blank spot on tool tabs. r=nhnt11
Attachment #9073428 - Attachment description: Bug 1548076. Try to focus on devtool even if the click hit blank spot on tool tabs. r=nhnt11 → Bug 1548076. Try to focus on devtool even if the click hit blank spot on tool tabs. r=pbro
Attachment #9073428 - Attachment is obsolete: true

(In reply to Patrick Brosset <:pbro> (off until July 22nd) from comment #4)

I can't reproduce either.
Here are my steps:

  • open a page

  • open DevTools

  • click inside the content page (to make sure focus is there)

  • press Cmd + to zoom in ==> the page zooms in, which is expected. DevTools does not, which is expected too.

  • click inside DevTools (to make sure focus is there)

  • press Cmd + to zoom in ==> the DevTools toolbox zooms in, which is expected. The content page does not, which is expected too.

Now, I did notice one buggy case:

  • click in the page to move the focus there
  • now click somewhere in the toolbar of anywhere in DevTools (where the tools are listed)
  • press Cmd + ==> the page zooms in, which is not expected.

Are you getting something different dmurvihill?

I followed your procedure exactly. In the final step, the content page zoomed in and DevTools did not -- the opposite of the behavior you reported.

The buggy case you pointed out is occurring for me in all cases, regardless of where I click inside the tool window.

Flags: needinfo?(dmurvihill)

New, very interesting info I discovered just now:

Cmd + in the dev window zooms in the content page
Cmd = (same key, don't touch Shift) in the dev window zooms in the dev tools.

Attachment #9073608 - Attachment description: Bug 1548076. Let the devtools gain focus even if the click hit the blank spot on UI. r=jdescottes → Bug 1548076. Let the devtools gain focus even if the click hits an empty area on UI. r=jdescottes
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a22e6caaafe1
Let the devtools gain focus even if the click hits an empty area on UI. r=jdescottes,yzen
Assignee: nobody → herpiko
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
QA Whiteboard: [qa-69b-p2]
You need to log in before you can comment on or make changes to this bug.