Provide a way to block the loading of addons without blocking everything else

RESOLVED FIXED in Firefox 68

Status

enhancement
P1
normal
RESOLVED FIXED
2 months ago
Last month

People

(Reporter: mkaply, Assigned: jdescottes)

Tracking

(Blocks 2 bugs)

unspecified
Firefox 68
Dependency tree / graph

Firefox Tracking Flags

(firefox68 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

2 months ago

In enterprise policy, folks want to block the installation of addons.

If they do that, we need to prevent the loading of addons via about:debugging.

Right now all we can do is block about:debugging completely.

It would be nice if there was someway to simply remove the Load Temporary Addon button if addon blocking is enabled.

:mkaply, which pref is blocking for blocking installation of addons that about:debugging should use to hide the button?

Flags: needinfo?(mozilla)
Reporter

Comment 2

2 months ago

If xpinstall.enabled is locked to false.

There's also a new policy coming, but if the infrastructure is there, I can just hook into it.

Flags: needinfo?(mozilla)
Assignee

Updated

2 months ago
Assignee

Comment 3

2 months ago

It would be nice if there was someway to simply remove the Load Temporary Addon button if addon blocking is enabled.

If we fix this in 68, this needs to be fixed in both the old about:debugging (which can still be enabled with a pref) and the new one.

For the new about:debugging I would just hide the whole temporary extension section.
For the old one we should just hide the button.

It makes sense to adapt the aboutdebugging UI here, but the root cause should also be fixed IMO. The AddonManager.installTemporaryAddon should not allow extensions to be installed when this pref is false.

Assignee

Updated

2 months ago
Blocks: 1548135
Assignee

Updated

2 months ago
See Also: → 1548139
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Priority: -- → P1

Comment 5

Last month
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/af96bd1090b5
Hide temporary addon category in about:debugging when xpinstall.enabled is false r=daisuke

Comment 6

Last month
bugherder
Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
You need to log in before you can comment on or make changes to this bug.