Closed Bug 1548104 Opened 7 months ago Closed 7 months ago

Sometimes Ctrl-Backspace highlights a word instead of deleting it

Categories

(Firefox :: Address Bar, defect)

68 Branch
x86_64
Windows 10
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1545731
Tracking Status
firefox68 --- affected

People

(Reporter: overholt, Unassigned)

References

Details

Attachments

(1 file)

(This might be a duplicate of bug 835779 but I don't think it's been happening to me for more than a few months.)

I have a few potential completions offered when I type the word "new" into my awesomebar. If I use the arrow keys to go down to the Gmail compose URL and press Ctrl-Backspace, I can reliably make the word "new" not delete but instead get highlighted.

To bisect this we'd need to get a profile with a few history entries containing the same substring and then do something like:

  • go to awesomebar
  • type common substring from a few history entries
  • use arrow down key to select the one which ends (maybe this is the key here?) in the common substring
  • press Ctrl-Backspace to delete said common substring
Has Regression Range: --- → no
Has STR: --- → yes

I verified this behaviour remains the same with browser.urlbar.quantumbar set to true.

I should note that I'm trying to delete a section of the URL (like a query parameter), not delete the item from my history.

(In reply to Andrew Overholt [:overholt] from comment #1)

  • use arrow down key to select the one which ends (maybe this is the key here?) in the common substring
  • press Ctrl-Backspace to delete said common substring

I can make it happen with "globe" from globeandmail.com and pressing Ctrl-Backspace or with a query parameter on a Google Doc so I was wrong about the common substring thing.

Assignee: nobody → adw
Status: NEW → ASSIGNED
Points: --- → 3
Priority: -- → P1

Actually -- this looks like bug 1545731 (see comment 3 and later).

Andrew, thanks for reporting this. I just want to make sure before duping it -- you mentioned in all your comments pressing the down arrow key to first select a result before backspacing, but your video doesn't show the popup. I'm guessing you captured the browser window only, which ended up excluding the popup? It does look like you maybe pressed down to arrive at the mail.google.com result.

The problem is that if you press down to select a result that is also eligible to be autofilled and then delete text at the end, autofill ends up getting triggered. IIRC we always autofill paths in URLs regardless of their frecency -- they're always eligible for autofill -- so if you select a result with a path in it and delete text, it autofills.

And it does happen in both awesomebar and quantumbar, unfortunately.

Flags: needinfo?(overholt)

(In reply to Drew Willcoxon :adw from comment #4)

I just want to make sure before duping it -- you mentioned in all your comments pressing the down arrow key to first select a result before backspacing, but your video doesn't show the popup. I'm guessing you captured the browser window only, which ended up excluding the popup? It does look like you maybe pressed down to arrive at the mail.google.com result.

Yes. I thought the Windows screen recorder thing would capture it but it doesn't.

The problem is that if you press down to select a result that is also eligible to be autofilled and then delete text at the end, autofill ends up getting triggered. IIRC we always autofill paths in URLs regardless of their frecency -- they're always eligible for autofill -- so if you select a result with a path in it and delete text, it autofills.

Yeah.

For posterity, I'll write out another STR so we're on the same page and then you can dupe:

  1. have https://bugzilla.mozilla.org/enter_bug.cgi?product=bugzilla.mozilla.org&component=Administration in your history
  2. open a new tab and type |admin| and the above is offered as the first autofill option
  3. press down arrow to select that one and Ctrl-Backspace delete the word "Administration", hoping to Ctrl-Backspace your way to "product=" (yes, I wouldn't win at vim golf)
  4. Notice that the word "Administration" hangs on to the end of the URL bar as you repeatedly Ctrl-Backspace
Flags: needinfo?(overholt)

Thanks!

Assignee: adw → nobody
Status: ASSIGNED → RESOLVED
Points: 3 → ---
Closed: 7 months ago
Priority: P1 → --
Resolution: --- → DUPLICATE
Duplicate of bug: 1545731
You need to log in before you can comment on or make changes to this bug.