Closed Bug 1548155 Opened 5 months ago Closed 3 months ago

Text disappears when mouseover/mouseout description

Categories

(Core :: DOM: CSS Object Model, defect, P3)

defect

Tracking

()

RESOLVED INVALID
mozilla69
Tracking Status
firefox-esr60 --- wontfix
firefox66 --- wontfix
firefox67 --- wontfix
firefox68 --- wontfix
firefox69 --- wontfix

People

(Reporter: alice0775, Assigned: emilio)

References

(Depends on 1 open bug, )

Details

(Keywords: nightly-community, parity-chrome, parity-edge)

Attachments

(3 files)

Reproducible: always

Steps to reproduce:

  1. open url
  2. Mouseover description text and then mouseout

Actual Results:
The description text disappears

workaround:

@-moz-document domain("myanimelist.net") {
.js-synopsis {
width: 155px !important;
}
}

Attached file reduced html
Attached file testcase html

let elm = document.querySelector(".scroll");
let DOMRectWidth = elm.getBoundingClientRect().width;
let computedStyleWidth = window.getComputedStyle(elm).width;
alert(DOMRectWidth == parseInt(computedStyleWidth));

Firefox returns true.
Chrome and Edge returns false.

Component: Layout: Scrolling and Overflow → DOM: CSS Object Model

Thanks for filing this and for the reduced test-case Alice!

Flags: needinfo?(emilio)

Calling this P3 since it's longstanding behavior and this is the only interop issue we know about here, but I still want to take a look at this.

Priority: -- → P3
See Also: → 1504607

See the note in the test about the .tentative.html bit. I really thing Gecko
behavior is sane here.

I filed https://bugs.chromium.org/p/chromium/issues/detail?id=973171 about this,
and told the Blink folks to file a csswg-drafts issue if they disagreed.

Sorry for the lag here. I think this is an issue with Chrome / Edge, and that our behavior is reasonable.

So I think this should be invalid, and I'll land a test.

I filed https://bugs.chromium.org/p/chromium/issues/detail?id=973171, but if they disagree we should discuss in the CSS WG and figure out where to go from here.

Flags: needinfo?(emilio)
Assignee: nobody → emilio
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d92e38d89823
Add a WPT test to ensure that getComputedStyle() round-trips when scrollbars are present. r=bzbarsky
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/17329 for changes under testing/web-platform/tests
Upstream web-platform-tests status checks passed, PR will merge once commit reaches central.
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Upstream PR merged

Based on comment 7, I'm calling this invalid. Feel free to reopen the bug if the spec discussion ends up changing that viewpoint.

Flags: in-testsuite+
Resolution: FIXED → INVALID

I know this was marked invalid but it actually got fixed by something and the testcase and original website that experienced the issue now works.

It seems like the website has been fixed, probably. The reduced test-case still fails. Note that this is not an issue on Mac, since scrollbars don't take layout space there.

You need to log in before you can comment on or make changes to this bug.