click-and-hold registers a click event in mail window

VERIFIED DUPLICATE of bug 137877

Status

SeaMonkey
MailNews: Message Display
--
minor
VERIFIED DUPLICATE of bug 137877
16 years ago
13 years ago

People

(Reporter: olsonle, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
PowerPC
All

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Reproducible:  always
Steps to reproduce:
1.  Click-and-hold on a mail folder in the folder pane, or on a message in the
message list pane.
2.

Actual results:  context menu opens, and the selected item also opens.

Expected results:  if we consider click-and-hold analogous to a right-click in
the more-than-one-mouse-button world (*sigh*) only the context menu should
appear, the item itself should not be opened unless a "left-click" event occurs.

This behavior (as far as I can tell) doesn't occur in the message pane.

I see this also in an older OS 9 build (2002052917) in the classic environment.

This may or may not be the desired behavior-- I personally think, in the
Windows/Linux/other builds, it's kinda nice to be able to right-click on an
unread message, file it to another folder, and still have it marked as unread in
the other folder.  In the Mac builds, as already described, clicking-and-holding
will open it (and thus mark it as read) before it can be filed.  Not a huge
problem for me, just a little inconvenient to have to open the other folder and
re-mark it as unread.
(Reporter)

Comment 1

16 years ago
Oops, forgot some info...

Using build 2002062803 on OS X v. 10.1.5

Comment 2

16 years ago
bug 137877 is basically about the same issue
(Reporter)

Comment 3

16 years ago
Good call, I don't know why I couldn't find that bug when I searched for it...

*** This bug has been marked as a duplicate of 137877 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.