Closed Bug 1548359 Opened 9 months ago Closed 9 months ago

Consider to finish forget skippable phase sooner if there is idle time to use

Categories

(Core :: DOM: Core & HTML, enhancement, P2)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1548358

People

(Reporter: smaug, Assigned: smaug)

Details

Attachments

(1 file)

Right now we may end up calling CCRunnerFired quite a few times before deciding to stop it or call CC - meaning there are quite some wake-ups even if the browser is otherwise rather idle.
I was thinking that maybe we could finish sooner, just try to find some slice which would do some work. Or the recursive call will just kill the CCRunner if there isn't anything to do.
Note, the earlier 'else if' still forces the most important forgetSkippable calls and such.

Calling the method recursively is just the easiest way to implement the approach.
The return value of the method is true, if some work was done.

(still away from my main machine, so moz-phab doesn't work. Misusing data-review)

Attachment #9061993 - Flags: data-review?(continuation)
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1548358
Attachment #9061993 - Flags: data-review?(continuation)
You need to log in before you can comment on or make changes to this bug.