Closed Bug 1548362 Opened 9 months ago Closed 8 months ago

TalkBack selection misplaced after page zoom

Categories

(GeckoView :: General, defect, P2)

Unspecified
Android
defect

Tracking

(geckoview66 wontfix, firefox-esr60 wontfix, firefox66 wontfix, firefox67 wontfix, firefox68 fixed, firefox69 fixed)

RESOLVED FIXED
mozilla69
Tracking Status
geckoview66 --- wontfix
firefox-esr60 --- wontfix
firefox66 --- wontfix
firefox67 --- wontfix
firefox68 --- fixed
firefox69 --- fixed

People

(Reporter: asa, Assigned: eeejay)

Details

(Whiteboard: [geckoview:fenix:p3])

Attachments

(1 file)

Steps to reproduce
Enable TalkBack
Load a webpage
Swipe to select an element on the page
Pinch to zoom the page in

Expected behavior
The TalkBack focus rectangle should stay on the originally selected element

Actual behavior
The TalkBack focus rectangle moves to some random place on the page

Device information

Android device: Samsung Galaxy S6, Android version 7.0
Fenix version: 2019-04-03

See also https://github.com/mozilla-mobile/fenix/issues/1474

Eitan, what priority do you think this bug should be? How frequently will someone using TalkBack also zoom the page?

Flags: needinfo?(eitan)
Priority: -- → P3

I would match the Fenix issue. I think p2.

A TalkBack user with residual sight might depend on page zoom.

Flags: needinfo?(eitan)
OS: All → Android
Priority: P3 → P2
Whiteboard: [geckoview:fenix:p3]
Pushed by eisaacson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/be5b9ac813f5
Include visual viewport offsets in bounds and hittest calculations. r=Jamie
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Eitan, should we uplift this fix to Fennec/GeckoView 68 Beta? Fennec will move to the ESR 68 channel, so 68 is our last chance to squeeze in bug fixes before ESR.

Retroactively assigning this bug to Eitan since he fixed it. :)

Assignee: nobody → eitan
Flags: needinfo?(eitan)

Comment on attachment 9063565 [details]
Bug 1548362 - Include visual viewport offsets in bounds and hittest calculations. r?Jamie!

Beta/Release Uplift Approval Request

  • User impact if declined: Talkback users will have a broken experience when they use pinch zoom on pages
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This is an Android-only change that only affects TalkBack users.
  • String changes made/needed:
Flags: needinfo?(eitan)
Attachment #9063565 - Flags: approval-mozilla-beta?

Comment on attachment 9063565 [details]
Bug 1548362 - Include visual viewport offsets in bounds and hittest calculations. r?Jamie!

android a11y fix, approved for beta68

Attachment #9063565 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.