Preview is not cleared on mouse out

RESOLVED FIXED in Firefox 68

Status

defect
P2
normal
RESOLVED FIXED
2 months ago
19 days ago

People

(Reporter: jlast, Assigned: jlast)

Tracking

(Blocks 1 bug)

unspecified
Firefox 68
Dependency tree / graph

Firefox Tracking Flags

(firefox68 fixed)

Details

(Whiteboard: [debugger-mvp] [qa-68b-p2])

Attachments

(3 attachments, 2 obsolete attachments)

Assignee

Description

2 months ago

STR:

  1. Hover (repeatedly) over a variable when paused

ER: preview is canceled and not shown
AR: preview is started, not canceled, and not cleared until the user hovers on another variable

Assignee

Updated

2 months ago
Priority: -- → P2

I am not able to reproduce this one.
Are there any more specific STRs?

Honza

Flags: needinfo?(jlaster)
Assignee

Comment 3

Last month

Unfortunately it is tough to reproduce, but it happens once a day for me with regular usage.

Flags: needinfo?(jlaster)

Comment 4

Last month

This implements editor previews in a way that doesn't rely on mouseLeave events. It does this actively by using the event loop to poll whether it should clear or not, and if it's not hovered on the token or the preview, it clears the preview.

Comment 5

Last month
Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/03b1762fb073
Reimplement token previews without onMouseLeave.

Backed out changeset 03b1762fb073 (bug 1548369) for devtools failures at devtools/client/debugger/test/mochitest/browser_dbg-inspector-integration.js

Backout: https://hg.mozilla.org/integration/autoland/rev/9dd4eba320e64aea32ba5e62b96c14c93768427f

Failure push: https://treeherder.mozilla.org/#/jobs?repo=autoland&selectedJob=246655685&revision=03b1762fb0734dc1f58ce5453a8aef8770745538

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=246645954&repo=autoland&lineNumber=4261

18:47:48 INFO - TEST-PASS | devtools/client/debugger/test/mochitest/browser_dbg-inspector-integration.js | Inspector is shown. -
18:47:48 INFO - Leaving test bound
18:47:48 INFO - Entering test bound
18:47:48 INFO - Adding a new tab with URL: http://example.com/browser/devtools/client/debugger/test/mochitest/examples/doc-event-handler.html
18:47:48 INFO - Tab added and finished loading
18:47:48 INFO - Opening the toolbox
18:47:48 INFO - Buffered messages logged at 18:47:41
18:47:48 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/client/debugger/src/components/Editor/Breakpoint.js" line: 29}]
18:47:48 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/client/debugger/src/components/Editor/Breakpoint.js" line: 29}]
18:47:48 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/client/debugger/src/components/Editor/Breakpoint.js" line: 29}]
18:47:48 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/client/debugger/src/components/Editor/Breakpoint.js" line: 29}]
18:47:48 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/client/debugger/src/components/Editor/ColumnBreakpoint.js" line: 26}]
18:47:48 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/client/debugger/src/components/Editor/ColumnBreakpoint.js" line: 26}]
18:47:48 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/client/debugger/src/components/Editor/ColumnBreakpoint.js" line: 26}]
18:47:48 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/client/debugger/src/components/Editor/ColumnBreakpoint.js" line: 26}]
18:47:48 INFO - Toolbox opened and focused
18:47:48 INFO - Invoking in tab: synthesizeClick()
18:47:48 INFO - Waiting for state change: paused
18:47:48 INFO - Console message: [JavaScript Warning: "Use of nsIFile in content process is deprecated." {file: "resource://gre/modules/NetUtil.jsm" line: 245}]
18:47:48 INFO - Finished waiting for state change: paused
18:47:48 INFO - Finished waiting for state change: paused
18:47:48 INFO - Waiting for state change: selected source
18:47:48 INFO - Finished waiting for state change: selected source
18:47:48 INFO - Buffered messages logged at 18:47:42
18:47:48 INFO - Hovering at 5, 7
18:47:48 INFO - Buffered messages logged at 18:47:43
18:47:48 INFO - Console message: [JavaScript Warning: "onmozfullscreenchange is deprecated." {file: "http://example.com/browser/devtools/client/debugger/test/mochitest/examples/doc-event-handler.html" line: 1}]
18:47:48 INFO - Console message: [JavaScript Warning: "onmozfullscreenerror is deprecated." {file: "http://example.com/browser/devtools/client/debugger/test/mochitest/examples/doc-event-handler.html" line: 1}]
18:47:48 INFO - Console message: [JavaScript Warning: "Ignoring get or set of property that has [LenientThis] because the “this” object is incorrect." {file: "http://example.com/browser/devtools/client/debugger/test/mochitest/examples/doc-event-handler.html" line: 1}]
18:47:48 INFO - Hovering at 5, 7
18:47:48 INFO - Buffered messages logged at 18:47:44
18:47:48 INFO - Hovering at 5, 7
18:47:48 INFO - Buffered messages logged at 18:47:45
18:47:48 INFO - Hovering at 5, 7
18:47:48 INFO - Buffered messages logged at 18:47:46
18:47:48 INFO - Hovering at 5, 7
18:47:48 INFO - Buffered messages logged at 18:47:47
18:47:48 INFO - Hovering at 5, 7
18:47:48 INFO - Buffered messages finished
18:47:48 INFO - TEST-UNEXPECTED-FAIL | devtools/client/debugger/test/mochitest/browser_dbg-inspector-integration.js | Uncaught exception - failed to preview
18:47:48 INFO - Leaving test bound
18:47:48 INFO - GECKO(862) | console.warn: "Error while detaching the thread front: 'detach' request packet to 'server1.conn40.child1/context18' can't be sent as the connection is closed."
18:47:48 INFO - Removing tab.
18:47:48 INFO - Waiting for event: 'TabClose' on [object XULElement].
18:47:48 INFO - Got event: 'TabClose' on [object XULElement].
18:47:48 INFO - Tab removed and finished closing
18:47:48 INFO - GECKO(862) | console.warn: "Error while detaching the thread front: 'detach' request packet to 'server1.conn39.child1/context18' can't be sent as the connection is closed."
18:47:48 INFO - Removing tab.
18:47:48 INFO - Waiting for event: 'TabClose' on [object XULElement].
18:47:48 INFO - Got event: 'TabClose' on [object XULElement].
18:47:48 INFO - Tab removed and finished closing
18:47:48 INFO - GECKO(862) | MEMORY STAT | vsize 5789MB | residentFast 572MB | heapAllocated 150MB

Flags: needinfo?(jlaster)
Assignee

Comment 7

Last month

This implements editor previews in a way that doesn't rely on mouseLeave events. It does this actively by using the event loop to poll whether it should clear or not, and if it's not hovered on the token or the preview, it clears the preview.

Assignee: nobody → jlaster
Status: NEW → ASSIGNED
Whiteboard: [debugger-mvp]
Assignee

Comment 8

Last month

This implements editor previews in a way that doesn't rely on mouseLeave events. It does this actively by using the event loop to poll whether it should clear or not, and if it's not hovered on the token or the preview, it clears the preview.

Attachment #9065400 - Attachment is obsolete: true
Assignee

Updated

Last month
Depends on: 1552171

Comment 9

Last month
Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f460289202a1
Reimplement token previews without onMouseLeave.
Attachment #9064837 - Attachment is obsolete: true
Assignee

Updated

Last month
Flags: needinfo?(jlaster)
Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

Comment 11

Last month

When hovering from the preview of tokenA back to tokenA, the preview shouldn't unrender and the rerender.

Whiteboard: [debugger-mvp] → [debugger-mvp] [qa-68b-p2]

Comment 12

20 days ago
Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8a50fab3649d
Don't unrender preview when hovering from preview back to token. r=jlast
You need to log in before you can comment on or make changes to this bug.