CTRL+SHIFT+D does not work

CLOSED WORKSFORME

Status

SeaMonkey
Bookmarks & History
CLOSED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Ajay Gautam, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.1a+) Gecko/20020627
BuildID:    2002062704

CTRL+SHIFT+D does not work. It does not bring up thr "File Bookmark" Dialog. I
never tried this before, so I don't know if this worked in earlier versions or
other OSes.

Reproducible: Always

Thanks

Ajay Gautam
wfm with win2k build 20020626..

Comment 2

16 years ago
wfm WinME build 2002062808

Comment 3

16 years ago
Reporter :

1) Using a 3rd party theme ?
2) Clean install ?
3) Tried with a blank new profile.

WFM trunk build 2002062804 - WinXP.
(Reporter)

Comment 4

16 years ago
> 1) Using a 3rd party theme ?

none at all...

> 2) Clean install ?

Yes...

> 3) Tried with a blank new profile.

Not tried this. Will try monday and post again.

Thanks

Comment 5

16 years ago
WFM with Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1a+) Gecko/20020629
(Reporter)

Comment 6

16 years ago
Tried with the latest mozilla install today. Still am unable to get File
Bookmark dialog.

Mozilla 1.1a+
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.1a+) Gecko/20020702

Thanks

Ajay Gautam

Comment 7

16 years ago
Is it possible you are running another program that has a global key binding for
Ctrl-Shift-D?  

For example, Trillian has a global hotkey Ctrl-Shift-I that tells the program to
go to the next pending event (even while the focus is on another program). 
However, TextPad and I believe many other text editors, also use Ctrl-Shift-I to
reduce a tab indent.  Until I disabled the Trillian hotkey, I could never reduce
the tab indent when focused on the editor...
(Reporter)

Comment 8

16 years ago
> Is it possible you are running another program that has a 
> global key binding for Ctrl-Shift-D?

I don't think so, as nothing happens when I press C-S-D.

However, right now, I am using mozilla on XP on my home PC. C-S-D is working
right now. I will try again from office. Also will check if anyother software
captures it.

Thanks
Ajay
(Reporter)

Comment 9

16 years ago
This is working in Linux (Gentoo) as well.

I tried looking in my NT machine, could not find anything that would be
capturing CTRL-SHIFT-D.

Anything else I could try ?

Thanks

Ajay Gautam

Comment 10

16 years ago
When I mentioned the Trillian example, I forgot to mention that I had never used
its "pending event" feature, so I had no idea those keystrokes were being
captured by that program...I kind of discovered it one day serendipitiously
while playing around with its preferences.  

I know you searched for a program that might be capturing the sequence
Ctrl+Shirt+D - perhaps it's buried in some program's preferences?  Maybe start
each program one by one and see which program might be capturing it?  Other than
that, I'm sorry; that's the only thing I can think of...  Good luck :)

Comment 11

16 years ago
using ICQ? see Ctrl+Shift+D
(Reporter)

Comment 12

16 years ago
Not using ICQ.

Comment 13

16 years ago
Ajay, are you able to reproduce this on a recent build?
(Reporter)

Comment 14

16 years ago
Yes, The build that i am using is  2002100409 and yes, am still not able to get
it on this machine (nt).

Works fine on my laptop (winxp) at home.

Any ideas ?

Thanks

Comment 15

16 years ago
Maybe set the keyboard shortcut of a Start Menu item to Ctrl+Shift+D
and see what happens when you press C+S+D in Mozilla?
(Reporter)

Comment 16

16 years ago
Not set as shortcut in start menu. nothing happens when I press C+S+D anywhere.
Tried:

In all open windows
When no window in selected
In the start menu

No response to C+S+D anywhere.

Got suspecious: may be C+S+... has a problem. Found that C+S+F is linked to web
search. Tried it in mozilla. Works fine. So, the keyboard/keys are ok.

Any other suggestions ?

Thanks

Ajay

Comment 17

16 years ago
Ajay, did you ever try to reproduce this with a new profile?

Comment 18

16 years ago
what I meant was that you set the keyboard shortcut of a Start Menu
item to Ctrl+Shift+D, then in another application, press Ctrl+Shift+D
and see if the item launches, and then in Mozilla do the same thing.
If Ctrl+Shift+D doesn't bring up the item in either application, then
something is stealing the keystrokes.
(Reporter)

Comment 19

16 years ago
> Ajay, did you ever try to reproduce this with a new profile?

Not intentionally. My computer (NT) crashed a few weeks back. So, I had to
re-install mozilla, which created a brand new profile... Does not work.

> ...
> what I meant was that you set the keyboard shortcut of a Start
> Menu item to Ctrl+Shift+D
> ...

Wow, I never knew you could do that. Anyway, I tried (but failed) to set the
short cut of an application (Leech FTP) to C+S+D. When I press C+S, the short
cut window shows "Ctrl + Shift +" The moment I press "D", the text changes back
to "None". I am able to set other keys such as C+S+G or C+S+S...

Looks fishy :( It does seem like some application is trying to capture that key.

Thanks

Comment 20

16 years ago
for documentation purpose, it would be nice to know what is capturing
the key...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 21

16 years ago
Ahhhh.... Finally....

Well I found out what was capturing the C+S+D: Palm Desktop

Here is how I found out: After typing the last response, I closed all apps,
opened task manager, performed "end task" on all tasks. The ones that remained
were system "un-end-able" tasks, then I started explorer, tried to set C+S+D as
a shortcut: was sucessful :), cancelled the short cut, started mozilla, pressed
C+S+D and presto: it worked!

I rebooted, started mozilla. Closed 1 app at a time and tested C+S+D, found that
after I closed palm desktop, it worked. I started palm again, it stopped working
again.

So, thats the culprit.

Plam is too important to me to give up due to this. I will go and bug those guys
now. I did find a work around: Close palm app, set C+S+D as a shortcut to an
app, start palm again. remove short cut. Now mozilla work with C+S+D :) However
this will only work in cases similar to mine: when I have palm and my desktop
running 24/5 :)

Thanks a lot to all you guys for helping me find the cause.

Ajay Gautam
Status: RESOLVED → CLOSED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.