Closed Bug 1548410 Opened 2 years ago Closed 2 years ago

Blacklist Windows on ARM C630 driver 23.18.9310.0

Categories

(Core :: Audio/Video: Playback, task)

task
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox67 --- fixed
firefox68 --- fixed
firefox71 --- affected

People

(Reporter: ajones, Assigned: cpearce)

References

(Blocks 1 open bug, Regressed 1 open bug)

Details

Attachments

(1 file)

There are a number of issues with this driver on the Windows on ARM platform including green frames and BSOD crashes. The green frames issues are expected to be fixed in the updated driver.

This driver version is known to have busg which cause the output of green
frames from the decoder, and to cause BSODs.

Pushed by cpearce@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/849b94e89135
Disable DXVA on Qualcomm WoA drivers. r=mattwoodrow
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Duplicate of this bug: 1548699

Reproduced on Windows 10 on ARM platform (Laptop Lenovo Yoga) on the latest Beta 67.0b17.

Chris, is that something we could uplift to 67?

Flags: needinfo?(cpearce)

Comment on attachment 9062076 [details]
Bug 1548410 - Disable DXVA on Qualcomm WoA drivers. r?mattwoodrow

Beta/Release Uplift Approval Request

  • User impact if declined: BSODs while playing video
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This blacklists the driver for hardware video decoding on a specific Windows on ARM64 device; we'll fallback to software decoding, which will not be as performant, but will be more stable.
  • String changes made/needed: None
Flags: needinfo?(cpearce)
Attachment #9062076 - Flags: approval-mozilla-beta?

(In reply to Pascal Chevrel:pascalc from comment #6)

Chris, is that something we could uplift to 67?

Yes! Requested uplift.

Comment on attachment 9062076 [details]
Bug 1548410 - Disable DXVA on Qualcomm WoA drivers. r?mattwoodrow

Arm64 stability fix, approved for our beta branch.

Attachment #9062076 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Regressions: 1550454
Regressions: 1549962
Regressions: 1550445

Given the regressions we should probably back this out from beta and m-c.

Flags: needinfo?(cpearce)

Or... Hmm. I guess those regressions aren't as bad as the BSOD that this update is trying to fix. Chris, what do you think?

There is supposed to be a new driver coming to these devices soon, and once that's released the regressions from this should be fixed. Probably best to await the new driver and let this ship.

Flags: needinfo?(cpearce)
Type: defect → task
Duplicate of this bug: 1533710

Looks like we're still waiting for the new driver for machines on the default channel. My machine is on Windows 1903, and after checking for new drivers today I'm still seeing 23.18.9310.0.

We are encountering the same BSOD on the arm64 laptops - on latest Nightly 70.0a1 - with the following drivers:

Driver provider: Qualcomm Incorporated
Diver date: 1/24/2019
Driver version: 25.18.10440.0

Windows 10 Home
Version 1809 (OS Build 17763.615)

Reproduced on Windows 10 on ARM platform (Laptop Lenovo Yoga) on the latest Nightly 71.0a1.

I have GPU driver 10.0.18362.1 as the latest available driver in Windows 10 v1903 OS build 18362.418.
What is the latest official driver for Qualcomm Adreno 630 now?
23.18.9310.0 got blacklisted and there is also 25.18.10440.0, but where do I get it from? is it official or non-official?
Which driver should we actually use for testing?

Flags: needinfo?(chris)

(In reply to Bodea Daniel [:danibodea] from comment #18)

I have GPU driver 10.0.18362.1 as the latest available driver in Windows 10 v1903 OS build 18362.418.
What is the latest official driver for Qualcomm Adreno 630 now?
23.18.9310.0 got blacklisted and there is also 25.18.10440.0, but where do I get it from? is it official or non-official?
Which driver should we actually use for testing?

25.18.10440.0 appears official and looks to be delivered via Windows update (my machine has it without any manual install). I'd use 25.18.10440.0 for testing.

Flags: needinfo?(chris)

If you uninstall the device (Qualcomm Adreno 630 display adaptor), do you get the same driver? I don't.

Flags: needinfo?(bvandyk)

My ARM device has Windows version 10.0.18362, and Adreno 630 GPU driver 25.18.10440.0.

If I uninstall the display adapter and search for hardware changes I get driver version 2.18.9310.0 and prompting Windows to search for driver updates has it say I'm on the most recent driver. However, looking through the driver updates in Window's updates, it looks like previously there are driver's installed by Lenovo.

Not clear how to restore the old drivers, or if we're going to have to wait until another Windows delivered update. I would suggest anyone else reading this does not downgrade their drivers.

Flags: needinfo?(bvandyk)

It's a fairly severe option, but after scouring the web and speaking to Lenovo support I arrived at resetting the install on my ARM device via Windows Settings -> Recovery -> Reset this PC and wiping my data. This does end up having having Windows update reinstall the drivers, at the cost of wiping the computer.

The way to switch from using the Microsoft driver (10.0.18362.1, Basic Display Adapter) to the Qualcomm driver (25.18.10440.0, Adreno 630) is the following:

  1. You need to go to the System Update application installed on Lenovo by default and perform an drivers update check.
  2. You need to go to the Windows Update section and a new update should be available, the Qualcomm GPU driver.

I may be mistaken, but I believe I tried both the Lenovo System Update as well as the Windows Update, and neither was able to reinstall the driver once it had already been installed (and removed).

See Also: → 1592826
You need to log in before you can comment on or make changes to this bug.