Closed Bug 1548481 Opened 6 months ago Closed 2 months ago

Rewrite telemetry-related assertions used in Add-ons Manager tests to make use of TelemetryTestUtils

Categories

(Toolkit :: Add-ons Manager, task, P2)

task

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox68 --- wontfix
firefox69 --- wontfix
firefox70 --- fixed

People

(Reporter: rpl, Assigned: rpl)

Details

Attachments

(1 file)

Same as Bug 1548479 but for the AddonsManager tests:

There are a bunch of tests that are using custom test helpers to make assertions on the telemetry events recorded and they should be rewritten to use the TelemetryTestUtils instead.

Assignee: nobody → lgreco
Status: NEW → ASSIGNED
Priority: -- → P2
Pushed by luca.greco@alcacoop.it:
https://hg.mozilla.org/integration/autoland/rev/31e37db859a9
Rewrite assertions used in Add-ons Manager tests to make use of TelemetryTestUtils. r=mstriemer,mixedpuppy
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

Since the status are different for nightly and release, what's the status for beta?
For more information, please visit auto_nag documentation.

Hello,

Will this fix require manual validation? If yes, please provide some steps to reproduce in order to correctly test it and also, please set the "qe-verify+" flag. Otherwise, could the "qe-verify-" flag be added? Thanks!

Flags: needinfo?(lgreco)
Flags: needinfo?(lgreco) → qe-verify-
You need to log in before you can comment on or make changes to this bug.