[wayland] Flickering after wayland popup heirarchy was changed

RESOLVED INVALID

Status

()

defect
P3
major
RESOLVED INVALID
4 months ago
3 months ago

People

(Reporter: kennylevinsen, Unassigned)

Tracking

(Blocks 2 bugs, Regression, {regression})

Firefox Tracking Flags

(Not tracked)

Details

SharedGL was enabled by bug 1535893 for wayland.

This has resulted in peculiar flickering when multiple windows are present. On Sway, this is seen as an odd surface extending from the right and bottom edges of the window, which seems to toggle on/off every time the cursor moves a pixel.

It is most easily seen to be covering the status bar if set at the bottom, and due to my configuration of Sway forcing a 10px gap around all windows, it can also be seen covering the background on the right of the window.

Other surfaces also sometimes end up flickering, such as context menus or web extension overlays.

Testing shows that the issue was not present prior to merging bug 1535893, but is present after.

Regressed by: 1535893
Blocks: wayland, wr-linux
Priority: -- → P3
Keywords: regression

I had misidentified the regression as being caused by SharedGL activation on Wayland together with another regression, but is in fact caused wayland popup heirarchy being changed by bug 1532643. Backing that patch out (manually) solves the issue.

Sorry for the confusion.

Regressed by: 1532643
No longer regressed by: 1535893
Summary: [wayland] Flickering after SharedGL was enabled → [wayland] Flickering after wayland popup heirarchy was changed

Compositor test:

  • Sway (wlroots): Flicker
  • Rootston (wlroots): OK
  • Weston: OK
  • Gnome: OK

This may be a Sway issue. See https://github.com/swaywm/sway/issues/4191.

This issue was identified as a damage tracking issue in sway for subsurfaces attached to xdg_popups. It has been fixed in master with https://github.com/swaywm/sway/pull/4193.

Marking as resolved.

Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
Resolution: --- → INVALID
Duplicate of this bug: 1552020
You need to log in before you can comment on or make changes to this bug.