Closed Bug 1548528 Opened 7 months ago Closed 7 months ago

“Check for Updates” from detailed view does not display new permissions pop-up

Categories

(Toolkit :: Add-ons Manager, defect)

68 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
Tracking Status
firefox66 --- unaffected
firefox67 --- disabled
firefox68 --- verified

People

(Reporter: cbadescu, Unassigned)

References

Details

Attachments

(2 files)

Attached image CheckForUpdates.gif

[Affected versions]:

  • Firefox 68.0a1(20190502095227)

[Affected platforms]:

  • Win 7 64-bit
  • Mac OS X 10.14.1

[Prerequisites]

  • Set the preference extensions.htmlaboutaddons.enabled to true and restart the browser

[Steps to reproduce]:
1.Install an older version of an extension (https://addons.mozilla.org/en-US/firefox/addon/to-google-translate/versions/ ).
2.Select Extensions from about:addons.
3.In Manage Your Extensions, hover over the more options menu button.
4.Click on “More Options” button.
5.Check the “Off” radio button from “Allow automatic updates”.
6.Click on the “Check for Updates” link.

[Expected results]:

  • The pop-up with new permissions to be displayed.

[Actual results]:

  • There is no pop-up displayed for the new permissions and the extension is successfully updated.

Please see the attached video.

There was a bad rebase when landing the patch. This has since been fixed in a follow up. Can you verify if it's fixed, please? Thanks.

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Attached image Bug1548528.gif

This issue is verified as fixed on Firefox 68.0a1 (20190507214514) under Win 7 64-bit and Mac OS X 10.14.1.

Please see the attached video.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.