etrade.com - banking area navigation doesn't work in mozilla

RESOLVED FIXED in Oct

Status

RESOLVED FIXED
17 years ago
4 years ago

People

(Reporter: thomas-mzll-01, Unassigned)

Tracking

unspecified
x86
Windows XP

Details

(Whiteboard: [login required], URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1a) Gecko/20020617
BuildID:    2002061712

If you try to click on the navigation links at the top of the page referenced
above (which use javascript), the page will go blank, and it will appear as if
the page is in the process of being loaded, but nothing ever happens. 

The JavaScript console shows the following error after I click on a link:

Error: document.BankHeader has no properties
Source File:
https://a248.e.akamai.net/n/248/1777/20020605/bank.etrade.com/global_fns.js
Line: 61

Reproducible: Always
Steps to Reproduce:
1. Go to this URL: https://banking.etrade.com/servlet/serena45online/SetAccount
2. Click the "Accounts" button, near the top, next to "Home."

Actual Results:  Page goes blank, and the action icon continues to animate as if
the page is being loaded, but nothing ever happens.

Expected Results:  The page should be loaded.

It's due to a javascript error, yet MSIE works fine with this navigation.

Similar navigation can be found on etrade here:

https://us.etrade.com/e/t/applogic/logout

And this works fine in Mozilla. So it seems specific to their banking area of
the website.
(Reporter)

Comment 1

17 years ago
Created attachment 89586 [details]
The .js file that contains the actual error.

I've included the .js file from akamai.net, just in case we lose access to it
for some reason.
both work for me perfect (?)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

17 years ago
To see this bug, you might have to be logged in to their banking area. I wasn't
able to reproduce it until I did that just now.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Whiteboard: [login required]

Comment 4

17 years ago
OSCP validation returns an unauthorized response.
Summary: etrade.com banking area navigation doesn't work in mozilla → etrade.com - banking area navigation doesn't work in mozilla

Updated

16 years ago
Keywords: evang500
please check if this problem still exists, because we want to get rid of
unconfirmed bugs.
Many bugs in here are strill unconfirmed, because eigher nobody sees the problem
or nobody is able to get to the page because of a required login.

(sorry for the spam)
(Reporter)

Comment 6

16 years ago
Unfortunately I no longer have an ETRADE account, so I can't confirm if this is
still a problem. Hopefully someone else here can check it.

Comment 7

16 years ago
tech evang june 2003 reorg
Assignee: aruner → english-us
Component: US Ecommerce → English US
QA Contact: bc → english-us

Comment 8

15 years ago
confirming for now. I have written to them asking for a confirmation of their
support policy for Mozilla.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → Oct

Comment 9

15 years ago
<reply>
Thank you for choosing E*TRADE Financial.

We currently support Mozilla 1.0.  If we can be of further assistance please let
us know.  Thank you for your correspondence.

For further assistance, please use our E*TRADE Financial Help center at
https://us.etrade.com/e/t/estation/helpcenter, or call us at 1-800-786-2575 or
(916) 636-2510 if outside the US.
</reply>

marking fixed. please reopen if you disagree.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago15 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.