Open Bug 1548609 Opened 3 years ago Updated 3 years ago

Rendering glitch when navigating in Angular

Categories

(Core :: Web Painting, defect, P3)

68 Branch
Desktop
All
defect

Tracking

()

Tracking Status
firefox-esr60 --- wontfix
firefox66 --- wontfix
firefox67 --- wontfix
firefox68 --- wontfix
firefox69 --- fix-optional

People

(Reporter: chris, Unassigned)

References

(Regression)

Details

(Keywords: regression, reproducible)

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

Visit https://givingtools.com/ask and scroll all the way to the bottom of the page. Then scroll back up to the top and click the "Q&A" navigation link. Scroll down a little bit and you'll see content from the previous page still being rendered behind the expandable questions.

I've tested this on the latest Firefox Nightly (v68.0a1 (2019-05-02) (64-bit)) as well as on my laptop running v66.03. Both running Ubuntu 18.04. My boss originally discovered this issue on his Mac running Firefox v66.0.1.

Actual results:

Content that has been removed is still visible until something overlays it (e.g. inspect element box overlays, resizing the page, switching tabs).

Expected results:

Well, I don't expect this glitch to appear.

Attached image nmadngedakngoppo.png

I can also reproduce the issue on Nightly68.0a1 Windows10.

Status: UNCONFIRMED → NEW
Component: Untriaged → Graphics: Layers
Ever confirmed: true
Keywords: reproducible
Product: Firefox → Core
OS: Unspecified → All
Hardware: Unspecified → Desktop

esr60 is also affected :(

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=fa3be8644d73a8ef20333924c11b70c5bc034fdf&tochange=ce7f71c2f402beaebf1485323144830e8743fffa

Regressed by: Bug 1382534

And I can confirm that set layers.async-pan-zoom.enabled to false fixes the issue on Nightly68.0a1 Windows10.

Has Regression Range: --- → yes
Has STR: --- → yes
Component: Graphics: Layers → Panning and Zooming
Keywords: regression
Regressed by: 1382534
Blocks: apz-desktop

I can also confirm that setting layers.async-pan-zoom.enabled to false and restarting Firefox also fixes the issue for me on Nightly 68.0a1 Ubuntu 18.04.

Component: Panning and Zooming → Web Painting

What method are you using to perform the scroll (keyboard, mousewheel, touchpad, autoscroll, etc.)?

(In reply to Botond Ballo [:botond] from comment #6)

What method are you using to perform the scroll (keyboard, mousewheel, touchpad, autoscroll, etc.)?

I'm using the mouse wheel, but I can also reproduce it if I drag the scroll bar.

I can't reproduce it, however, if I use the page up/down keys or up/down arrow keys.

At least I can reproduce the issue with following method
using mouse wheel
using autoscroll
using dragging thumb of scrollbar.

I cannot reproduce the issue using keyboard(I tried several times, but not reproduced).
I do not have touchpad device.

I have not been able to reproduce this so far, testing the latest Nightly on Debian stable. I've tried all three of the mentioned methods.

I can reproduce this on macOS. WebRender is off.

Based on the symptoms, this seems like a latent graphics bug that was exposed by layerizing masks, rather than a bug in the mask clip computation (which is what previous regressions from bug 1382534 have been).

Build ID 20190506130308
User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

screencast https://youtu.be/yO2z6VnuyuU

Priority: -- → P3

I'm not seeing this issue anymore, probably because we are now lazy loading those images (as of 5/20/19).

I can still reproduce the issue on Nightly69.0a1 Windows10.
Build ID 20190604214415
User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

You need to log in before you can comment on or make changes to this bug.