css text not displayed with negative percent indent in positive percent padded <TD>.

RESOLVED DUPLICATE of bug 148240

Status

()

Core
DOM: CSS Object Model
--
minor
RESOLVED DUPLICATE of bug 148240
16 years ago
16 years ago

People

(Reporter: Jeremy Kallstrom, Assigned: jst)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Here is the simple html of the page that shows what isn't working.  I have 
a table set up with the second column in the first raw having 10% padding 
on the left.  When I try to display a negatively-indented headline in the 
cell it doesn't display(using a negative %, absolute negative number works 
fine).  I'm not entirely sure that I'm expecting the correct behavior, but 
it works as expected in opera 6.1 and netscape 4.79 just fine.

<html>
<head>
<style>
TD.cl1 {padding-left: 10%}

H2 {text-indent: -5%}
</style>
</head>
<body>

<TABLE>
<TR>
<TD>Some stuff here</TD>
<TD class="cl1">
<H2>Testing</H2>
Some writing
</TD>
</TR>
</TABLE>
</body>
</html>
(Reporter)

Comment 1

16 years ago
Forget to mention, it behaves the same way with an externally linked text/css 
file.
Jeremy, I cannot reproduce this and a fix for this went into the trunk on June
3.   If you are using a trunk build from June 4 or later (please always list
your build ID in bug reports!) then reopen this bug.

*** This bug has been marked as a duplicate of 148240 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.