Closed Bug 1548680 Opened 9 months ago Closed 9 months ago

Address bar incorrectly autocompletes numeric addresses

Categories

(Firefox :: Address Bar, defect)

66 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1537640

People

(Reporter: jon, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Steps to reproduce:

Begin typing an https URL with a numeric address in the address bar. For example, https://10.11.12.13

(version 66.0.3 64-bit for Windows, English/United States)

Actual results:

Address is autocompleted to https://10.0.0.0 with the cursor immediately after the first dot is typed, and remainder of the text after the cursor not highlighted. Continued typing leaves the remainder, so a fully typed address might come out as https://10.11.12.13/0.0.0

When using http:// the cursor jumps to the end of the autocompleted address after typing the first dot.

Named addresses do not exhibit this behavior.

Observed on two separate systems with unrelated profiles.

Expected results:

Address should autocomplete with remainder after the cursor highlighted to allow overtype.

Component: Untriaged → Address Bar

This is a duplicate of bug 1537640 that will be fixed in Firefox 67

Status: UNCONFIRMED → RESOLVED
Closed: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1537640
You need to log in before you can comment on or make changes to this bug.