Closed Bug 1548694 Opened 1 year ago Closed 1 year ago

Intermittent tools/profiler/tests/browser/browser_test_profile_page_info.js | This test exceeded the timeout threshold. It should be rewritten or split up. If that's not possible, use requestLongerTimeout(N), but only as a last resort. -

Categories

(Core :: Gecko Profiler, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox68 --- fixed
firefox69 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: canova)

References

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

Filed by: ncsoregi [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=244287036&repo=mozilla-inbound
Full log: https://queue.taskcluster.net/v1/task/NY9qpku4S3q8Rt9fwReQmA/runs/0/artifacts/public/logs/live_backing.log


[task 2019-05-02T21:00:51.382Z] 21:00:51 INFO - TEST-PASS | tools/profiler/tests/browser/browser_test_profile_page_info.js | 2 == 2 -
[task 2019-05-02T21:00:51.393Z] 21:00:51 INFO - Leaving test bound test_profile_multi_frame_page_info
[task 2019-05-02T21:00:51.395Z] 21:00:51 INFO - Buffered messages finished
[task 2019-05-02T21:00:51.397Z] 21:00:51 INFO - TEST-UNEXPECTED-FAIL | tools/profiler/tests/browser/browser_test_profile_page_info.js | This test exceeded the timeout threshold. It should be rewritten or split up. If that's not possible, use requestLongerTimeout(N), but only as a last resort. -
[task 2019-05-02T21:00:51.404Z] 21:00:51 INFO - GECKO(5982) | MEMORY STAT | vsize 1177MB | residentFast 624MB | heapAllocated 334MB
[task 2019-05-02T21:00:51.405Z] 21:00:51 INFO - TEST-OK | tools/profiler/tests/browser/browser_test_profile_page_info.js | took 91975ms

hey nazim, looks like we'd need to split this file in several files.

Flags: needinfo?(canaltinova)

huh, it's weird. I actually split those into two in the first place because of that. But apparently it wasn't enough. Will split more.

Assignee: nobody → canaltinova
Status: NEW → ASSIGNED
Flags: needinfo?(canaltinova)

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:canaltinova, could you have a look please?
For more information, please visit auto_nag documentation.

Flags: needinfo?(canaltinova)

This is on purpose.
Nazim, maybe we could close this bug WONTFIX for now?

Flags: needinfo?(canaltinova)

Hey nazim, there are more intermittents on other platforms than win32, do you think we should move forward with the split ?

Flags: needinfo?(canaltinova)

Yeah, I think it would be good to land this patch since the other intermittents. I'm doing it now.

Flags: needinfo?(canaltinova)
Pushed by canaltinova@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/89664bfdb628
Split the profiler page information tests to prevent intermittent timeout r=julienw
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
You need to log in before you can comment on or make changes to this bug.