Closed Bug 1548699 Opened 7 months ago Closed 7 months ago

Unexpected green video frame was rendered

Categories

(Core :: Audio/Video: Playback, defect)

Unspecified
Windows 10
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1548410

People

(Reporter: alwu, Unassigned)

References

Details

Forked from bug1535847 comment26, on Windows10 aarch64, we would get the unexpected green video frame which should not happen because the test file only contains white frame.

Here are some failures, you can check the acutal rendering result via open analyser button on the top.

https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=243783542&repo=mozilla-central&lineNumber=12984

https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=243610175&repo=mozilla-central&lineNumber=12953

Hi, Matt, Jya,
Do you have any idea about why we would get this green video frame on Windows?
Thank you.:jya

Flags: needinfo?(matt.woodrow)
Flags: needinfo?(jyavenard)

Green frames usually happen because we've converted a YUV frame containing all 0s to RGB.

I guess that means that the decode failed somewhere, and we're still trying to present the blank frame?

Flags: needinfo?(matt.woodrow)

isn't that a driver issue as seen in bug 1548410?

Flags: needinfo?(jyavenard)

It seems that we ran tasks on lenovo yoga c630[1], it looks like bug1525656. Should we blacklist this driver as well?

[1] https://tools.taskcluster.net/provisioners/bitbar/worker-types/gecko-t-win64-aarch64-laptop

Flags: needinfo?(jyavenard)

(In reply to Alastor Wu [:alwu] from comment #4)

It seems that we ran tasks on lenovo yoga c630[1], it looks like bug1525656. Should we blacklist this driver as well?

[1] https://tools.taskcluster.net/provisioners/bitbar/worker-types/gecko-t-win64-aarch64-laptop

we are disabling those drivers, it was done in bug 1548410.
now we have to wait for Windows to release the new ones.

Flags: needinfo?(jyavenard)

It seems like a driver issue and we've disabled it on bug 1548410.

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1548410
You need to log in before you can comment on or make changes to this bug.