Closed Bug 1548869 Opened 7 months ago Closed 7 months ago

Blocklist profile-after-change observer is set up incorrectly

Categories

(Toolkit :: Blocklist Implementation, defect)

60 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: aswan, Assigned: kmag)

References

(Regression)

Details

Attachments

(1 file)

Prior to bug 1524688, this observer was set up for non-desktop builds:
https://searchfox.org/mozilla-central/rev/da054397cdad072c8c61b463d374bc012b5f12aa/toolkit/mozapps/extensions/extensions.manifest#3-5

But the registration logic was inadvertently flipped when this was converted to static registration:
https://searchfox.org/mozilla-central/rev/b59a99943de4dd314bae4e44ab43ce7687ccbbec/toolkit/mozapps/extensions/components.conf#14-16

I think this means we're loading the blocklist earlier than needed on desktop and later than intended on android.

We're supposed to register this category for everything other than desktop
Firefox. Instead, we currently register it only for desktop Firefox.

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.