Incorrect "Request Desktop Site" translation to Russian language

RESOLVED FIXED

Status

defect
RESOLVED FIXED
Last month
Last month

People

(Reporter: nekr, Assigned: a)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

Last month

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36

Steps to reproduce:

  • Set Android system language to Russian.
  • Navigate to any website and open Firefox menu

Actual results:

  • It says "Полная версия сайта" (direct translation: "Full version of website") as localization to "Request Desktop Site"

Expected results:

  • Should say something like "Версия для компьютера" (Version for a computer) or "Декстоп версия" ("Desktop version" using the same sounding word for "desktop") or "Версия для ПК" (Version for PC)

The "Full version of website" line implies that currently viewed version is somehow stripped down or being "not a full version". Even if in some cases it is true, it isn't the dominant case this days (and it shouldn't).

The mistake has been made because the phrase "Full version" in context of desktop version is quite popular in Russia, although the meaning is very wrong.

I believe it's time to change this situation. We (vk.com, Russian #1 social network) already have made a change and stopped using "full version" wording on our mobile website. We now use "Версия для компьютера" ("Version for a computer")

Recently we talked with Google Chrome and they agreed to make the change, it's in Stable (72) channel right now. The wording has changed from "Полная версия" ("Full version") to "Версия для ПК" ("PC version"). https://bugs.chromium.org/p/chromium/issues/detail?id=902093

Also Samsung Internet browser is implicitly onboard with this thing since they always had correct wording. which is "Запросить версию для ПК" ("Request the PC version").

Other browsers are still with the incorrect "Полная версия" ("Full version"), but I'm reaching to one browser at a time. I already filled an issues for Safari (as you know its bugtracker is not public).

Please consider making this change.
Thank you.

Reporter

Comment 1

Last month

Forgot to mention that it's the same on iOS.

Axel, where should this go?

Flags: needinfo?(l10n)
Component: Locale switching and selection → ru / Russian
Product: Firefox for Android → Mozilla Localizations
Version: Firefox 66 → unspecified

Redirect to the mobile lead for the Russian localization. Does this request seem correct?

Flags: needinfo?(l10n) → needinfo?(unghost)
Assignee

Comment 4

Last month

Hi everyone,

Спасибо большое, Артур! I'm agree with your explanations. These days most sites developed with adaptive/responsive design, so 'full version' is wrong. The fixes for Firefox for Android, Firefox for iOS and other Mozilla projects just have been made. We're a bit late to the party, for Firefox for Android we've have L10N deadline - 30 April, and for Firefox for iOS - 1 May, so most likely we'll see changes in the next release.

Patch link: https://pontoon.mozilla.org/ru/all-projects/all-resources/?time=201905051030-201905051130&string=197566

Status: UNCONFIRMED → RESOLVED
Closed: Last month
Flags: needinfo?(unghost)
Resolution: --- → FIXED
Assignee

Updated

Last month
Assignee: nobody → a
Reporter

Comment 5

Last month

Awesome, thank you! <3

You need to log in before you can comment on or make changes to this bug.